Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#17205 closed defect (fixed)

dojox/form/BusyButton does not fire submit event in Chrome

Reported by: williambr Owned by: dante
Priority: high Milestone: 1.8.8
Component: DojoX Form Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

I hit a small bug. dojox/form/BusyButton of type submit does not fire the form "submit" event once it is hit, in Chrome. it works in Firefox, I did not test in other browsers.

This is new to 1.9.0, worked as expected in 1.8.x.

Here is an example: http://jsfiddle.net/umHBj/1/

Run in Chrome, click submit and it will not log the message set in "submit". Chaange it to Dojo 1.8.4, run it again and voila.

kitsonk in IRC told be to create it. I did not find anything related in trac as it is new with 1.9.0, so I'm sorry if it is a duplicate.

Thanks

Change History (13)

comment:1 Changed 6 years ago by bill

Component: GeneralDojoX Form
Owner: set to dante

comment:2 Changed 6 years ago by dtamm

I can confirm this one. One of my customers recently stepped over this bug, now he changed to firefox portable for the next few days. I will maybe have a look into the source code to help you out, when i am back in my office today (comparision of 1.8.4 and 1.9.x may help me with this i hope)

comment:3 Changed 6 years ago by Sébastien Le Ray

This is a duplicate of #9075. I just provided a quick fix there

comment:4 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #9075.
Thanks for catching that.

comment:5 Changed 6 years ago by williambr

I am not sure this is a duplicated. How come it worked fine with 1.8.X and #9075 is from ages ago?

comment:6 Changed 6 years ago by bill

Resolution: duplicate
Status: closedreopened

Now that you mention it, it does sound like a different bug.

comment:7 Changed 5 years ago by freddefisk

Seems to be an issue with disabling the submit button in chrome. See this jsfiddle where it's reproduced in pure javascript: http://jsfiddle.net/5zLj7yug/

comment:8 Changed 5 years ago by freddefisk

Proposed fix: https://github.com/dojo/dojox/pull/139

In the mean time, a workaround is to manually submit the form when the button is clicked.

comment:9 Changed 5 years ago by dylans <dylan@…>

Resolution: fixed
Status: reopenedclosed

In 80c654a9388bf34e4d1ad7087eba756940d43501/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 5 years ago by dylans <dylan@…>

In 4e5ba3b861f8b3bd0f162a35aedd1e739a71c04e/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 5 years ago by dylans <dylan@…>

In 5907ea929ad632da3d9733d5439986e028c8fc0e/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:12 Changed 5 years ago by dylans <dylan@…>

In c79fac218b1f44823c004f447d33ec0e31efa8f4/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:13 Changed 5 years ago by dylan

Milestone: tbd1.8.8
Priority: undecidedhigh

Backported to 1.8 (fix did not cleanly apply to 1.7)

Note: See TracTickets for help on using tickets.