Opened 6 years ago

Closed 6 years ago

#17202 closed defect (invalid)

issues with TitlePane as a child of BorderContainer

Reported by: ben hockey Owned by: ben hockey
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

http://jsbin.com/ohezom/1/edit shows 2 distinct problems with TitlePane? as a child of BorderContainer?.

  1. when the title pane toggles from open -> closed or closed -> open the layout is broken. maybe there should be a way for the child to signal to the parent that layout needs to happen again?
  2. when the title pane is closed and the parent needs to layout the children again (eg resizing the sidebar), the title pane does not adjust it's size (in this case it's width).

Change History (4)

comment:1 Changed 6 years ago by bill

Owner: set to ben hockey
Status: newpending

BorderContainer wasn't designed to handle (arbitrary) children that change size. That's what dojox/layout/ExpandoPane was designed for. Doesn't using ExpandoPane? (instead of TitlePane?) fix your problem?

comment:2 Changed 6 years ago by ben hockey

Owner: changed from ben hockey to bill
Status: pendingassigned

ExpandoPane? has it's own set of issues. an example is here http://jsbin.com/ohezom/2/edit

  1. styling is awful (i could probably improve this with some effort)
  2. the title disappears when it's collapsed and i need something that displays it's title when collapsed (i can probably get this to work with some CSS too)

but regardless of ExpandoPane? and setting aside that BC wasn't designed to handle children that change size (this is my point 1 above and i can work around this), there's still the 2nd problem i mentioned... the title pane doesn't resize properly when it's closed. even if it's in another layout container if resize is called when the title pane is closed, it's effectively ignored when it really should still adjust it's width.

comment:3 Changed 6 years ago by bill

Owner: changed from bill to ben hockey
Status: assignedpending

ExpandoPane? has it's own set of issues

Yes, they should be fixed, maybe you can fix them.

title pane doesn't resize properly when it's closed. even if it's in another layout container if resize is called when the title pane is closed, it's effectively ignored when it really should still adjust it's width

I didn't even think a TitlePane?.resize() method existed.

So, I'm not seeing any reason to fix this ticket. At some point we'll probably fold in the ExpandoPane? functionality into BorderContainer?, but for the time being ExpandoPane? is what's supposed to do what you are trying to do.

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.