Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#17200 closed defect (fixed)

CheckBox and RadioButton display wrong status in IE9 and IE10.

Reported by: 15413 Owned by: bill
Priority: undecided Milestone: 1.7.6
Component: Dijit - Form Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

CheckBox? and RadioButton? display wrong status in IE9 and IE10.

See dijit/tests/form/CheckBox.html in IE9 or IE10.

The dojo version is 1.8, 1.9.

Attachments (7)

dojo-checkbox.jpg (38.2 KB) - added by 15413 6 years ago.
check.swf (213.0 KB) - added by 15413 6 years ago.
checkbox mouse over and click
normal(standard view)-IE10.jpg (121.7 KB) - added by 15413 6 years ago.
normal(standard view)-IE10
Compatibility View-IE10.jpg (111.1 KB) - added by 15413 6 years ago.
Compatibility View-IE10
1.jpg (28.4 KB) - added by Prateep Gedupudi 6 years ago.
2.jpg (11.5 KB) - added by Prateep Gedupudi 6 years ago.
3.jpg (11.6 KB) - added by Prateep Gedupudi 6 years ago.

Download all attachments as: .zip

Change History (36)

Changed 6 years ago by 15413

Attachment: dojo-checkbox.jpg added

comment:1 in reply to:  description Changed 6 years ago by bill

Component: GeneralDijit - Form
Owner: set to Douglas Hays

Are you saying the problem is that the disabled checkbox shows enabled? I don't know how you got that screenshot, but it's working for me on IE9.

comment:2 Changed 6 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

Please try http://archive.dojotoolkit.org/nightly/checkout/dijit/tests/form/test_CheckBox.html in your IE9/10. This link works for me using both IE browser versions.

comment:3 Changed 6 years ago by 15413

Move the mouse over the checkboxs you will see that checkbox's status change.

Last edited 6 years ago by 15413 (previous) (diff)

comment:4 Changed 6 years ago by bill

I don't know what you mean by "status" but I'm not noticing any wrong behavior when mousing over the checkboxes on IE9.

comment:5 Changed 6 years ago by Douglas Hays

cwocwo, is this problem on Windows 8? I'm wondering if this is some kind of touch support artifact since I'm not seeing a problem on Win 7/XP.

comment:6 Changed 6 years ago by bill

I tried on IE10 on Windows 8 and didn't notice any incorrect or irregular behavior.

comment:7 Changed 6 years ago by 15413

I tested it on Win7. The following attachment is the screen record.

Changed 6 years ago by 15413

Attachment: check.swf added

checkbox mouse over and click

comment:8 Changed 6 years ago by bill

I can't even read that format of attachment. But now you are saying the issue happens when you mouse over and then click? I tried that On IE9/Win7 and it's working fine.

comment:9 Changed 6 years ago by 15413

Could you download the attachment? It's a swf. You can play it with flash player.

comment:10 Changed 6 years ago by bill

OK, I saw it. Unfortunately I still can't reproduce it (and Doug can't either). Very weird behavior. It would be interesting to know what your browser and document settings are (they are visible after hitting F12).

comment:11 Changed 6 years ago by 15413

I used the IE normally. But the checkoxs and radios work fine in the compatibility view on IE10. I can reproduce it every time on IE10 but IE9.

Changed 6 years ago by 15413

normal(standard view)-IE10

Changed 6 years ago by 15413

Attachment: Compatibility View-IE10.jpg added

Compatibility View-IE10

comment:12 Changed 6 years ago by bill

I can reproduce it every time on IE10 but IE9.

You left off the end of your sentence, so I don't know what you mean. Regardless, unfortunately I can't reproduce it on IE10. See https://saucelabs.com/tests/5d458fcb683f4277aaf2e87eaf694b64#.

Perhaps you can make an open-source account on saucelabs and try to reproduce it.

comment:13 Changed 6 years ago by 15413

I can't reproduce it every time on IE9. I can reproduce it every time on IE10.

comment:14 Changed 6 years ago by mitchell

I had same problem as cwocwo but I got the problem fixed. Search keyword like "opacity:0.01" in file dijit/themes/claro/claro.css(file path may vary depending on dojo version or build path), change whatever matches searches to "opacity:0" and then the problem in this ticket will be gone. In most cases "opacity:0.01" gets overwritten by "filter:alpha(opacity=0)" and that is why this bug is hard to replicate; in your case the 0.01 opacity breaks CSS of dojo checkboxes and radio buttons.

comment:15 Changed 6 years ago by bill

FWIW the 0.01 is from #2420, and presumably we needed it (rather than plain opacity:0) to fix behavior on some browser, but I don't know whether it was gecko or webkit, and whether or not it's still an issue.

comment:16 Changed 6 years ago by Dimtry

Looks like still valid issue. I have it in IE11 and had in IE10 on 2 computers but have not on all other accessible for me. Thus the issue is very rare. Solution from mitchell is work for me. If you don't wont to change the dojo sources just add .dj_ie .dijitCheckBoxInput {opacity: 0;} in your style to overwrite 0.01 value for IE (and leave as is for other browsers. look at bill's comment). And don't forget about tri state checkbox from dojox.

comment:17 Changed 6 years ago by Colin Snover

If you are going to repeat that this is an issue, please provide a valid test case that reproduces it. Please provide details about the system you are using, and what kind of pointer input it has. Please explain if you have changed any system settings or IE options from the Windows defaults. There have been 3 committers now that have reviewed this issue and do not reproduce any problem.

Last edited 6 years ago by Colin Snover (previous) (diff)

comment:18 Changed 6 years ago by clayjm

I'm able to reproduce this in IE10. In an environment of several thousand computers (~10 different models), I'm seeing a trend of two models experiencing the issue. All computers use the same image and OS/Browser settings are managed the same across each model.

Common Factors Dell Models (Optiplex 760 and 780)* Windows 7 SP1* IE 10.0.10 and 10.0.11 (others may be impacted)* 4 GB RAM* Intel 4 Series Internal Chipset Display Adapter (various versions of the driver including latest 8.15.10.2869, A15 1/15/2013)

*Other models in the environment, not experiencing the issue also share these common factors.

Setting the Document Mode to IE9 Standards resolves the issue. I don't own the impacting site (using Dojo 1.3), but able to reproduce using the Radio Button Example in the Reference Guide (1.9.2).

Doesn't matter if you use the mouse or keyboard to interact with the form, the display shows as if buttons get selected an unselected without actually making a selection. Multiple radio buttons appear selected. It's entirely visual, the selected item(s) are the correct items returned when results are displayed.

I can provide additional detail if needed, let me know if I can help.

Version 0, edited 6 years ago by clayjm (next)

comment:19 Changed 6 years ago by Colin Snover

clayjm could you please try installing the official Intel driver please, from https://downloadcenter.intel.com/Default.aspx?lang=eng rather than installing the driver from Dell?

Changed 6 years ago by Prateep Gedupudi

Attachment: 1.jpg added

Changed 6 years ago by Prateep Gedupudi

Attachment: 2.jpg added

Changed 6 years ago by Prateep Gedupudi

Attachment: 3.jpg added

comment:20 Changed 6 years ago by Prateep Gedupudi

Thanks Clayjm. We were facing the same issue in Dell Latitude E6410. After installing graphics drivers from intel site issue got resolved. Please go through attachments 1,2,3.

comment:21 Changed 6 years ago by clayjm

Glad it worked for someone, but even after updating through Intel's site, I'm still experiencing the issue.

The latest available from Intel for the Q43/Q45 Driver is version 8.15.10.2869.

I'm now current on all Intel drivers according to the Intel Driver Update Utility.

comment:22 Changed 6 years ago by bill

Description: modified (diff)
Milestone: tbd1.10
Resolution: worksforme
Status: closedreopened

I had same problem as cwocwo but I got the problem fixed. Search keyword like "opacity:0.01" in file dijit/themes/claro/claro.css(file path may vary depending on dojo version or build path), change whatever matches searches to "opacity:0"

I will make this update if possible.

comment:23 Changed 6 years ago by bill

Owner: changed from Douglas Hays to bill
Status: reopenedassigned

The opacity: 0.01 originally came from 5b1c7465cd6039165e63a3f4b98c8492d325f4bb.

The current code is:

.dijitCheckBoxInput {
	/* place the actual input on top, but all-but-invisible */
	opacity: 0.01;
}

.dj_ie .dijitCheckBoxInput {
	filter: alpha(opacity=0);
}

ISTM the filter is always applied whenever opacity: 0.01 is present.

Nonetheless, I'll change it to opacity:0.

comment:24 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 4068c904425890334d5face9cb692815ae4db7bb/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:25 Changed 5 years ago by Bill Keese <bill@…>

In 7a391c43ca5145ec59e46765f478973e359c9f77/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:26 Changed 5 years ago by Bill Keese <bill@…>

In b343c470b3d41f0fd9eec94060377bd334e0c2b0/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:27 Changed 5 years ago by bill

Milestone: 1.101.8.7

comment:28 Changed 5 years ago by Bill Keese <bill@…>

In a4681a20442a3eed697d698943012106102f7ac9/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:29 Changed 5 years ago by bill

Milestone: 1.8.71.7.6
Note: See TracTickets for help on using tickets.