Opened 6 years ago

Closed 4 years ago

#17188 closed enhancement (duplicate)

dojox.mobile.ItemBase touch threshold value is sometimes far too little (4px): make it customizable

Reported by: Sebastien Brunot Owned by:
Priority: undecided Milestone: 1.11
Component: DojoX Mobile Version: 1.9.0
Keywords: Cc: dg
Blocked By: Blocking:

Description

The touch threshold cannot be adapted to the various use cases (in a list or not, wide item). It's difficult to tap on an item resulting as a buggy behavior of the application.

Change History (6)

comment:1 Changed 6 years ago by Sebastien Brunot

A tpouch threshold of 4px is actually defined (hardcoded) in the following components:

_EditableIconMixin _ItemBase ValuePickerSlot?

Note that SpinWheelSlot? uses a different threshold of 5px.

Last, scrollable.js define a threshold of 4px, but it can be overriden using the parameter scrollable.threshold.

Should we use a global touch threshold parameter for _EditableIconMixin, _ItemBase and ValuePickerSlot?, or define one attribute for each, or define one attribute only for _ItemBase ?

comment:2 Changed 6 years ago by dg

IHMO, it depends on the shape of the interactive item.

Concerning the item base (my use case), I think it should a threshold value per instance as it could be a button (a square) in a heading or a list item (wider element).

My 2 cents,

Damien

comment:3 Changed 6 years ago by Patrick Ruzand

Cc: dg added

comment:4 Changed 6 years ago by Patrick Ruzand

Milestone: tbd1.10

comment:5 Changed 6 years ago by Patrick Ruzand

Milestone: 1.10tbd

comment:6 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: duplicate
Status: newclosed

Duplicate of #16875.

Note: See TracTickets for help on using tickets.