Opened 7 years ago

Closed 7 years ago

#17186 closed defect (duplicate)

[regression] dojo/node! path error

Reported by: bill Owned by: Kitson Kelly
Priority: undecided Milestone: 1.8.5
Component: Core Version: 1.8.4
Keywords: Cc: Kitson Kelly, Colin Snover, ben hockey
Blocked By: Blocking:

Description

This is a regression from dojo 1.8.3 to dojo 1.8.4. To reproduce:

  1. Checkout js-doc-parse:
$ git clone --recursive https://github.com/csnover/js-doc-parse.git
  1. Copy and edit config.js as appropriate for your environment. For parsing Dojo Toolkit source, you should only need to set basePath to the path to your Dojo 1.8 checkout.
  1. Update dojo from 1.8.3 to latest:
$ cd dojo
$ git checkout master
  1. Run:
$ cd ..
$ ./parse.sh config=./config.js

It will give an error like:

DEBUG: 'failed to load resource (/ws/docparse/lib/processor/dojodoc.js)'
DEBUG: { [Error: Cannot find module '/ws/docparse/../marked/lib/marked.js'] code: 'MODULE_NOT_FOUND' }

Change History (4)

comment:1 Changed 7 years ago by bill

Cc: Kitson Kelly added
Milestone: tbd1.8.5
Owner: set to Kitson Kelly
Status: newassigned

I traced it to [dojo/133f6e2b86450d4445fa20d18edc7fb3a5388f70]. At least that's what "git bisect" tells me. So a regression from #16414.

comment:2 Changed 7 years ago by Kitson Kelly

Cc: Colin Snover ben hockey added

I can land Ben's diff if we want. I will do it as a PR to give the new workflow a spin.

comment:3 Changed 7 years ago by bill

Oh, I didn't realize that #16414 was reopened and had a patch. Well, if that fixes it that's good.

comment:4 Changed 7 years ago by Kitson Kelly

Resolution: duplicate
Status: assignedclosed

Duplicate of #16414.

Note: See TracTickets for help on using tickets.