Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#17185 closed defect (fixed)

[regression] dojox/widget/Wizard missing Button dependency

Reported by: Becca Stewart Owned by: bill
Priority: undecided Milestone: 1.9.1
Component: Dojox Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

Moving from 1.8.3, I encountered:

dojo/parser::parse() error parser.js (line 899) Error: Unable to resolve constructor for: 'dijit.form.Button' parser.js (line 182)

dojo/parser::parse() error parser.js (line 899) Error: dojox.widget.Wizard: parser returned unfilled promise (probably waiting for module auto-load), unsupported by _WidgetsInTemplateMixin. Must pre-load all supporting widgets before instantiation. _WidgetsInTemplateMixin.js (line 84)

Adding "dijit/form/Button", to /dojox/widget/Wizard.js appears to fix this.

Change History (3)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9.1
Owner: set to bill
Status: newassigned
Summary: dojox/widget/Wizard missing Button dependency[regression] dojox/widget/Wizard missing Button dependency

Ah, my fault, from my 346107f change to Wizard.js, I'll fix. (The JS file needs to include button because it's used from the template.)

comment:2 Changed 7 years ago by Bill Keese

Resolution: fixed
Status: assignedclosed

missing dependency, fixes #17185, refs #16492

Changeset: bfe2e0ae3f07a48bc517a98677544a10355f4263

comment:3 Changed 7 years ago by Bill Keese

missing dependency, fixes #17185, refs #16492

Changeset: 4f673e9d94493e9505eedd9b7d0c1c20e08fb7f3

Note: See TracTickets for help on using tickets.