Opened 6 years ago

Closed 6 years ago

#17184 closed defect (fixed)

[regression] dojox/widget/Portlet broken in Dojo 1.9

Reported by: achopra Owned by: cjolif
Priority: undecided Milestone: 1.8.5
Component: DojoX Widgets Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

dojox/widget/Portlet is broken in Dojo 1.9 because it depends on dojo.style which has been deprecated. dom-style must be used instead.

The bug is found at lines 54, 141, 166, 215, 242, 243 & 336 in the Portlet.js.uncompressed.js file.

I would thing the fix would be to simple import/require dom-style

and change dojo.style(...) to domStyle.set(...)

Change History (9)

comment:1 Changed 6 years ago by bill

Owner: set to achopra
Status: newpending

It seems like you're confused about what "deprecated" means. The test_Portlet.html test case is working fine for me, can you provide a test case that shows a failure?

comment:2 Changed 6 years ago by achopra

Status: pendingnew

I am using the Dojo 1.9.0 release build tarball.

When trying to create a simple portlet programatically, I get 'dojo.style is not a function'

and I get the following in the firebug console.

>>> dojo.style
undefined

The example on the nightly build site works! It is possible that the issue is already fixed but the release tarball does not have the fix yet. I will try the nightly build.

comment:3 Changed 6 years ago by bill

Milestone: tbd1.8.5
Owner: changed from achopra to cjolif
Status: newassigned
Summary: dojox/widget/Portlet broken in Dojo 1.9[regression] dojox/widget/Portlet broken in Dojo 1.9
Version: 1.9.01.8.0

OK, right, a regression from #15517.

comment:4 Changed 6 years ago by Christophe Jolif

refs #17184. Fixes the regression by making sure the AMD port is correct.

Changeset: 825f337fc0826bc1825a1a2894df57a3c4233391

comment:5 Changed 6 years ago by Christophe Jolif

Merge pull request #1 from cjolif/master

refs #17184. Fixes regression by making sure the AMD port is correct.

Changeset: 3bb633bb116bbcd08b6a5904a9546f82575b13ee

comment:6 Changed 6 years ago by Christophe Jolif

refs #17184. Fixes the regression by making sure the AMD port is correct.

Changeset: d1e488d431418ab43f8886c395d7872ca09d59cc

comment:7 Changed 6 years ago by Christophe Jolif

Merge pull request #2 from cjolif/1.9

refs #17184. Fixes the regression (1.9 backport)

Changeset: f9f891e624731646817eba52959cd040533c6fdc

comment:8 Changed 6 years ago by Christophe Jolif

refs #17184. Fixes the regression by making sure the AMD port is correct.

Changeset: b8202790de036a4e7da245d6f4a3ecccf4da70a2

comment:9 Changed 6 years ago by Christophe Jolif

Resolution: fixed
Status: assignedclosed

Merge pull request #3 from cjolif/1.8

fixes #17184. Fixes the regression (1.8 backport)

Changeset: 68c59ad515158ea4022c213328cb8d50562101bd

Note: See TracTickets for help on using tickets.