Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#17180 closed defect (duplicate)

[regression] require() in IE not working in 1.9

Reported by: Florian Owned by: Rawld Gill
Priority: undecided Milestone: 1.9.1
Component: Loader Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

it seems like ready() is no longer working in IE since 1.9 (at least version 8 + 9). I found a nice description for this problem at http://stackoverflow.com/questions/16544436/using-dojo-1-9-all-parsing-fails-in-ie which is exactly the same problem I am facing in my application.

Regards,

Florian

Attachments (1)

ie2.html (1.4 KB) - added by bill 7 years ago.
test file

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by bill

If you can give us a reproducible test case we'll take a look. I tried a few of my own test cases and it's working fine for me.

comment:2 Changed 7 years ago by bill

Component: GeneralLoader
Owner: set to Rawld Gill

Based on other reports, I doubt that ready() is even getting called. I think it's an issue w/require() never completing, and the callback never being called.

comment:3 Changed 7 years ago by bill

Milestone: tbd1.9.1
Summary: ready() in IE not working in 1.9[regression] require() in IE not working in 1.9

Changed 7 years ago by bill

Attachment: ie2.html added

test file

comment:4 Changed 7 years ago by bill

Reproducible from http://bill.dojotoolkit.org/dojo-release-1.9.0/ie2.html. Maybe it's caused by #17141. (You can see in IE's net tab that it's trying to load template files, and getting 404's.)

comment:5 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #17146.
Caused by #17141.

Last edited 7 years ago by bill (previous) (diff)
Note: See TracTickets for help on using tickets.