Opened 7 years ago

Closed 7 years ago

#17172 closed defect (worksforme)

FilteringSelect: height of blank option in dropdown too short

Reported by: Edwin Jacob Baby Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

We recently did dojo 1.5 to dojo 1.6 upgrade. We noticed that the space value that is present in the dropdown is showing with less height compared to the other values. When we add NULL as a value then its showing with proper height. Is this a dojo 1.6 issue?. This issue was not there with dojo 1.5.

Attachments (1)

dd issue.bmp (172.2 KB) - added by Edwin Jacob Baby 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Edwin Jacob Baby

Attachment: dd issue.bmp added

comment:1 Changed 7 years ago by bill

Owner: set to Douglas Hays
Status: newassigned

That's odd that you upgraded to 1.6 instead of 1.9. Can you attach a test case using the Attach File button?

You didn't say what widget was failing, is it Select?

comment:2 Changed 7 years ago by Edwin Jacob Baby

We are using dijit.form.FilteringSelect?. Its not failing. But its showing space value with very less height. I have attached a snapshot on that. You can find that here as well - https://bugs.dojotoolkit.org/attachment/ticket/17172/dd%20issue.bmp

comment:3 Changed 7 years ago by bill

Summary: Dojo 1.6 upgrade - Dropdown: Space value - height issue[regression] FilteringSelect: height of blank option in dropdown too short

OK got it. It would still be good if you attached a test case, as I requested about, so we can see how you are creating this blank value.

comment:4 Changed 7 years ago by Edwin Jacob Baby

I create the blank value in three ways.

1) As one of the value from the service call which will fetch blank value (" ") from the SQL that gets executed. (values fetched from the query will be directly listed in the drop down)

2) As a value in the option as shown below <option selected="selected" value=" ">&nbsp;</option>

3) Using splice data.items.splice(0,0,{"value":" "});

All these three are showing the height issue.

comment:5 Changed 7 years ago by Douglas Hays

Resolution: worksforme
Status: assignedclosed
Summary: [regression] FilteringSelect: height of blank option in dropdown too shortFilteringSelect: height of blank option in dropdown too short

Please attach a single HTML that can be loaded that demonstrates the problem. I added the blank option tag as you mentioned to dijit/tests/form/_autocomplete.html (v1.6)

<select id="preservetitletest" data-dojo-type="$testWidget"
                data-dojo-props='name:"titletest",
                style:{width:"50%", fontFamily:"Courier"},
                autoComplete:false,
                selectOnClick:true,
                pageSize:5,
                title:"New England States"
'>
        <option selected="selected" value=" ">&nbsp;</option>
        <option value="ct">Connecticut</option>
        <option value="me">Maine</option>
        <option value="ma">Massachusetts</option>
        <option value="nh">New Hampshire</option>
        <option value="vt">Vermont</option>
</select>

and then loaded the page to test via:

dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect

and the blank value is taking the same space as the other options. Your problem may be due to custom CSS or out out-of-date custom template. That's why a full HTML file is required. You may want to start with the _autocomplete.html file as a template to see if you can get it to fail there.

Note: See TracTickets for help on using tickets.