Opened 7 years ago

Closed 7 years ago

#17114 closed defect (invalid)

content is not refreshed in IE9 or IE10 with Dojo 1.8

Reported by: myu1 Owned by: myu1
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Our application is executing some asynchronous tasks. Periodically we callcurrentWidget.attr("content", content); to update the content in the ContentPane? to show the progress. If I look at the DOM, the new content is there but IE browser does not render it. It seems like IE9 or IE10 hangs while these asynchronous tasks are running and does not refresh the UI until the final task execution is completed. This works fine in FF, we use FF17.

Change History (2)

comment:1 Changed 7 years ago by bill

Component: GeneralDijit
Owner: set to myu1
Status: newpending

Hmm, that's very strange. Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.