Opened 6 years ago

Closed 6 years ago

#17101 closed defect (fixed)

[regression] dojox/form/TimeSpinner exception on creation

Reported by: adros Owned by: bill
Priority: undecided Milestone: 1.9.1
Component: DojoX Form Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

This changeset [30484/dojo] causes that TimeSpinner? is not working, because it does not have method _onKeyPress.

I have attached patch that fixes this issue.

Attachments (1)

timeSpinner.patch (580 bytes) - added by adros 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by adros

Attachment: timeSpinner.patch added

comment:1 Changed 6 years ago by bill

That doesn't fully fix it though; the code is still accessing e.charOrCode but that's not there anymore because it's a keydown event, not a synthetic keypress event. Should be e.keyCode IIRC.

comment:2 Changed 6 years ago by bill

Milestone: tbd1.9.1
Owner: changed from dante to bill
Status: newassigned
Summary: dojox/form/TimeSpinner not working[regression] dojox/form/TimeSpinner exception on creation

Anyway, thanks for the start of the patch, I'll check in a fix.

comment:3 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in [31420] and [31421], although I wrote the wrong ticket number in the checkin comment.

Note: See TracTickets for help on using tickets.