Opened 6 years ago

Closed 6 years ago

#17088 closed defect (duplicate)

Destroying a dialog on hide throws exception

Reported by: Randy Hudson Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

If I do:

	var dialog = new dijit.Dialog({
		title: "Title",
		content: dom,
		onHide:function(){dialog.destroyRecursive();}});
	dialog.show();

I hit an exception in Dialog when it tries to do this:

this._fadeOutDeferred.callback(true);

onHide is called right before that.

Change History (1)

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #12436.
This was fixed a long time ago, but if you can come up with a test case that fails against current code, attach it using the "Attach file" button and we'll reopen.

Note: See TracTickets for help on using tickets.