Opened 7 years ago

Closed 7 years ago

#17075 closed defect (duplicate)

Ctrl-C,Ctrl-V in Combobox and IE

Reported by: vita Owned by: Douglas Hays
Priority: undecided Milestone: 1.8.4
Component: Dijit - Form Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

In IE, when I paste any text in combobox, the new search is not performed. IE sends 'V' in the case Ctrl-V('C' in Ctrl-C), instead of expected 'v'/'c'.

Attachments (1)

searchmixin.patch (719 bytes) - added by vita 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by vita

Attachment: searchmixin.patch added

comment:1 Changed 7 years ago by Douglas Hays

vita, I just tried this on IE 8 and 9 and it's working for me (only lowercase characters are being sent with ctrlKey=true). I even tried turning caps lock on. Obviously the fix is trivial but I'd like to understand the scenario in which you see uppercase letters.

comment:2 Changed 7 years ago by vita

I tested it on about 4 computers with the same result. When I paste "Cal" in the empty combo on the page https://dojotoolkit.org/reference-guide/1.8/dijit/form/ComboBox.html (first example) then the combo do nothing. When I try it debug in IE-embeded debugger, i see 'V'/'X'(not 'v'/'c'). Tested configurations: 2xWin XP 5.1.2600 SP3 CZ, IE8.0.6001.18702; 1xWin Server 2003 STDE SP2 EN, IE8.0.6001.18702; 1xWin 7 PRO SP1 CZ, IE9.0.8112.16421

comment:4 Changed 7 years ago by vita

Sorry, I missed-I have sources from 1.8.3. Condition '"type" in evt && evt.type.substring(0,3) == "key"' make this problem ok. Although Ctrl-V comes as "V", the second event with type=paste starts search. Please close this ticket.

comment:5 Changed 7 years ago by Douglas Hays

Milestone: tbd1.8.4
Resolution: duplicate
Status: newclosed
Version: 1.9.0rc21.8.3

Duplicate of #16573.

Note: See TracTickets for help on using tickets.