Opened 6 years ago

Closed 6 years ago

#17073 closed defect (invalid)

IconItem moveTo overlays 2nd view on top of 1st view

Reported by: jonferraiolo Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.9.0b2
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description (last modified by Adam Peller)

I verified this problem with both dojo 1.8.3 and dojo 1.9.0rc1.

I have attached an HTML file (and associated screenshot) for a case where if you put a 'moveTo' property on an IconItem?, then clicking on the IconItem (using Mac/Chrome) will cause the second View will overlay the contents of the first View.

(The file was originally created in Maqetta, but then the Maqetta-specific markup was cleansed from the source code, and the effect happens without Maqetta being involved.)

Attachments (2)

iconitem-moveto-1.9rc1.html (4.7 KB) - added by jonferraiolo 6 years ago.
HTML source code
Screen Shot 2013-04-24 at 10.06.39 AM.png (91.7 KB) - added by jonferraiolo 6 years ago.
Screen snapshot showing currupted result

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by jonferraiolo

Attachment: iconitem-moveto-1.9rc1.html added

HTML source code

Changed 6 years ago by jonferraiolo

Screen snapshot showing currupted result

comment:1 Changed 6 years ago by Adam Peller

Cc: Adam Peller added
Component: GeneralDojoX Mobile
Description: modified (diff)
Owner: set to Eric Durocher
Version: 1.8.31.9.0b2

comment:2 Changed 6 years ago by Adrian Vasiliu

The behavior that you observe is due to the fact that your code specifies an unsupported value for the transition type:

<li label="Item 1" data-dojo-type="dojox/mobile/IconItem" 
  transition="below" ...>

while as documented the supported values are: "slide", "fade", "flip", "cover", "coverv", "dissolve", "reveal", "revealv", "scaleIn", "scaleOut", "slidev", "swirl", "zoomIn", "zoomOut", "cube", "swap", and "none".

Using for instance "slidev" instead of "below" fixes the problem in the browsers where I reproduced it with your code as-is. (Other browsers seem to tolerate it better.)

I tend to think it would be nice to provide error feedback in such case, however AFAIK this wouldn't be consistent with the current general Dojo policy (may change for 2.0).

For the time being, I'm closing the ticket, but of course feel free to ask to reopen if appropriate for some reason.

---

Finally, a few side-remarks about things that I've noticed in the sample code:

  1. It is not recommended to load deviceTheme using the AMD loader (for details and replacement solutions: livedocs.dojotoolkit.org/dojox/mobile/deviceTheme)
  2. As long as you use dojox/mobile widgets, I see no reason to set the claro class on body.
  3. Instead, it is generally recommended to set style="visibility:hidden;" on body, such that the user sees the app only once it is nicely styled.
  4. It would be better to set the widget properties in markup using data-dojo-props rather than as attributes.

These points don't matter for this issue but may cause troubles in other cases.

comment:3 Changed 6 years ago by Adrian Vasiliu

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.