Opened 6 years ago

Closed 6 years ago

#17066 closed defect (invalid)

Wrong alignment and selection problem on IE7 in ValidationTextBox with textDir=auto

Reported by: wajnberg Owned by: wajnberg
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

In order to reproduce the problem please do the following:

  • Open test_ValidationTextBoxes.html with IE 7
  • In the text box type an Hebrew letter followed by an english letter (you may have to install Hebrew keyboard in Regional Options on Windows)
  • The alignment should be at the right. Actually the text is left aligned (see Fig1 in the attachment)
  • Try to select the text you typed. The selection moves towards the rigth side (see Fig2 in the attachment)

Attachments (3)

test_ValidationTextBoxes.html (1023 bytes) - added by wajnberg 6 years ago.
Fig1.JPG (76.3 KB) - added by wajnberg 6 years ago.
Fig2.png (8.4 KB) - added by wajnberg 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by wajnberg

Changed 6 years ago by wajnberg

Attachment: Fig1.JPG added

Changed 6 years ago by wajnberg

Attachment: Fig2.png added

comment:1 Changed 6 years ago by bill

Component: GeneralDijit - Form
Owner: set to wajnberg
Status: newpending

Is this just IE7, or does it happen on IE8+? We aren't supporting IE6 and IE7 anymore.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.