Opened 6 years ago

Closed 6 years ago

#17039 closed defect (invalid)

Update of "checked" value is not observable with RoundRectStoreList

Reported by: rrblondo Owned by: rrblondo
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Eric Durocher)

If I create an observable memory store, assign it to RoundRectStoreList with select as "multiple", I am unable to observe changes in "checked".

Change History (5)

comment:1 Changed 6 years ago by Eric Durocher

Description: modified (diff)

Do you mean that changing the "checked" property of the store item does not result in the ListItem being checked? If yes, maybe this is a duplicate of #16643?

comment:2 Changed 6 years ago by Adrian Vasiliu

Summary: Update of "checked" value in not observable with RoundRectStoreListUpdate of "checked" value is not observable with RoundRectStoreList

comment:3 Changed 6 years ago by Sebastien Brunot

It seems to me that the RoundRectStoreList and EdgeToEdgeStoreList components only have a "read only" relation with the store: they update the displayed items when the store is updated, but you can't automatically update the content of the store by updating the items in the list.

When the list has the select property set to "single" or "multiple", clicking a list item will update the checked status of the item, but that will not update the corresponding checked property (if it exists) of the store item.

To update the store when the checked status of a list item is updated, It looks like you have to use the onCheckStateChanged method to be notified of the update, and write your own piece of code to update the content of the store...

If I'm right, that also means that this ticket should be turned into an enhancement request, rather than a defect.

comment:4 Changed 6 years ago by Eric Durocher

Owner: changed from Eric Durocher to rrblondo
Status: newpending

OK we definitely need more info on what is requested exactly, so I am returning this to the reporter.

comment:5 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.