Opened 7 years ago

Closed 7 years ago

#17014 closed defect (duplicate)

X Axis Label Missing

Reported by: watermelontang Owned by: Eugene Lazutkin
Priority: undecided Milestone: tbd
Component: Charting Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I would like to ask about the data point.

This is my code.

<html>
<head>
<link rel="stylesheet" href="../dojo-release-1.7.2/dijit/themes/claro/claro.css">
<script src="../dojo-release-1.7.2/dojo/dojo.js"  data-dojo-config="async:true, isDebug: false"></script>
<script type="text/javascript">
require(["dojo/ready",
// Require the basic chart class
"dojox/charting/Chart",

// Require the theme of our choosing
"dojox/charting/themes/Claro",
			
// Charting plugins: 

// 	We want to plot Lines 
"dojox/charting/plot2d/Lines",

// Load the Legend, Tooltip, and Magnify classes
"dojox/charting/widget/Legend",
"dojox/charting/action2d/Tooltip",
"dojox/charting/action2d/Magnify",
			
//	We want to use Markers
"dojox/charting/plot2d/Markers",

//	We'll use default x/y axes
"dojox/charting/axis2d/Default",

// Wait until the DOM is ready
"dojo/domReady!"
], function(ready,Chart, theme, LinesPlot, Legend, Tooltip, Magnify) {
		
ready(function(){
// Define the data
var chartData = [10000];
var chartData2 = [3000];
var chartData3 = [3000];


// Create the chart within it's "holding" node
var chart = new Chart("chartNode");

// Set the theme
chart.setTheme(dojox.charting.themes.Claro);

// Add the only/default plot
chart.addPlot("default", {
     type: "Lines",
     markers: true
});

// Add axes
chart.addAxis("x");
chart.addAxis("y", { min: 5000, max: 30000, vertical: true, fixLower: "major", fixUpper: "major" });

// Add the series of data
chart.addSeries("Monthly Sales - 2010",chartData);
chart.addSeries("Monthly Sales - 2009",chartData2);
chart.addSeries("Monthly Sales - 2008",chartData3);

var tip = new Tooltip(chart,"default");
							
// Create the magnifier
var mag = new Magnify(chart,"default");
					
// Render the chart!
chart.render();
					
// Create the legend
var legend = new Legend({ chart: chart }, "legend");
	
});
})
</script>
	
</head>
<body class="claro">
<div id="chartNode" style="width:auto;height:90%;"></div>
<div id="legend"></div>
</body>
</html>

I have data for each line and the output is like one point for each line. At the bottom of the graph, it doesn't show the label for each line.

Is that a defect?

Thanks for your generous help.

Elaine

Attachments (1)

Sample Output.jpg (35.1 KB) - added by watermelontang 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by watermelontang

Attachment: Sample Output.jpg added

comment:1 Changed 7 years ago by cjolif

Resolution: duplicate
Status: newclosed

Duplicate of #16994.

Note: See TracTickets for help on using tickets.