Opened 6 years ago

Closed 6 years ago

#17005 closed defect (duplicate)

_widgetbase setter function not called at creation

Reported by: lemon Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

the setter function is not called when the attribute has the value false. more abstract: _widgetbase.js line 443:

Step 2: Call set() for each property that wasn't passed as a parameter to the constructor array.forEach(list, function(attr){

if(attr in params){

skip this one, do it below

}else if(this[attr]){

this.set(attr, this[attr]);

}

}, this);

when this[attr] not equals true the setter function will not be called.

Change History (1)

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #7381.

Note: See TracTickets for help on using tickets.