Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#17004 closed defect (duplicate)

Object #<a MouseEvent> has no method 'stopImmediatePropagation' touch.js:115

Reported by: Sebastien Pereira Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.9.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

Method event.stopImmediatePropagation not supported on Android 2.x

Suggested patch:

Index: touch.js =================================================================== --- touch.js (revision 31184) +++ touch.js (working copy) @@ -112,7 +112,9 @@

if(!e._dojo_click &&

(new Date()).getTime() <= clickTime + 1000 && !(e.target.tagName == "INPUT" && domClass.contains(e.target, "dijitOffScreen"))){

  • e.stopPropagation();

+ if(e.stopPropagation){ + e.stopPropagation(); + }

e.stopImmediatePropagation();

if(type == "click" && (e.target.tagName != "INPUT"
e.target.type == "radio" e.target.type == "checkbox")

&& e.target.tagName != "TEXTAREA"){

Change History (3)

comment:1 Changed 7 years ago by Sebastien Pereira

Please ignore suggested patch in initial description. Correction should be:

Index: touch.js
===================================================================
--- touch.js	(revision 31184)
+++ touch.js	(working copy)
@@ -113,7 +113,9 @@
 								(new Date()).getTime() <= clickTime + 1000 &&
 								!(e.target.tagName == "INPUT" && domClass.contains(e.target, "dijitOffScreen"))){
 							e.stopPropagation();
-							e.stopImmediatePropagation();
+							if(e.stopImmediatePropagation){
+							     e.stopImmediatePropagation();
+							}
 							if(type == "click" && (e.target.tagName != "INPUT" || e.target.type == "radio" || e.target.type == "checkbox")
 								&& e.target.tagName != "TEXTAREA"){
 								 // preventDefault() breaks textual <input>s on android, keyboard doesn't popup,

Last edited 7 years ago by Sebastien Pereira (previous) (diff)

comment:2 Changed 7 years ago by Eric Durocher

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by Eric Durocher

Duplicate of #16999

Note: See TracTickets for help on using tickets.