Opened 6 years ago

Closed 5 years ago

#17000 closed defect (wontfix)

[dojox/mobile] Nested FixedSplitters do not resize correctly

Reported by: Paul Christopher Owned by: Patrick Ruzand
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description

Not really sure about this one:

Visit http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/mobile/tests/test_FixedSplitter-V2H2.html with a maximized browser window. Everything works fine. Now resize the browser window. The splitter starts to get white spaces.

Now visit http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/mobile/tests/test_FixedSplitter-V3.html with a maximized browser window. Again, resize the browser window. In this test case, no white spaces appear.

Could it be, that nested fixed splitters are broken somehow when resizing the window?

Attachments (1)

ticket17000.patch (3.1 KB) - added by Sebastien Brunot 6 years ago.
new attribute autoResize to automatically resize a top level FixedSplitter? when the browser window is resized (IBM CCLA).

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by Eric Durocher

Not sure what the expected behavior is exactly, but I think that's because the top and left panes have percent sizes. It they have fixed sizes in pixels, it works better. Arguably, you could probably say that it should not matter how the sizes are specified...

See also the test_FixedSplitter-orientation.html test, which is probably a more realistic case of how it would work on a mobile device.

Changed 6 years ago by Sebastien Brunot

Attachment: ticket17000.patch added

new attribute autoResize to automatically resize a top level FixedSplitter? when the browser window is resized (IBM CCLA).

comment:2 Changed 6 years ago by Sebastien Brunot

I've attached a patch with a proposal for a new attribute, autoResize, to set to true for a top level FixedSplitter? to automatically resize with the browser window. The patch also include a new manual test for this use case.

comment:3 Changed 6 years ago by Adrian Vasiliu

Milestone: tbd1.10
Owner: changed from Eric Durocher to Adrian Vasiliu
Status: newassigned

Changed the milestone from 1.9.1 to 1.10 because the patch introduces a new API, and the policy is that new APIs are introduced in major releases.

comment:4 Changed 5 years ago by Patrick Ruzand

Owner: changed from Adrian Vasiliu to Patrick Ruzand

comment:5 Changed 5 years ago by Patrick Ruzand

Milestone: 1.10tbd
Resolution: wontfix
Status: assignedclosed

The proposed patch is wrong. (You can't do such sync require() call). And having this global resize() listener in the lib scares me (we already have too much resize() processing. Since it's a quite specific issue, and the proposed patch is a possible workaround, I close as won't fix.

Note: See TracTickets for help on using tickets.