Opened 7 years ago

Closed 7 years ago

#16998 closed defect (duplicate)

dojo.Declaration - does not see data-dojo-args for declarative widget prototyping.

Reported by: idanielsteven Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

When creating a widget declaration in markup using

<div data-dojo-type="dijit.Declaration" ...>

The provided

<script type="dojo/method" ...>

functions for any particular widget i define do not recognize "data-dojo-args" attribute.

As a workaround, i've used "args" from the earlier practices of previous versions of dojo. However, "data-dojo-event" seems to work fine.

Change History (1)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9
Resolution: duplicate
Status: newclosed

Duplicate of #16303.

Note: See TracTickets for help on using tickets.