Opened 6 years ago

Closed 6 years ago

#16991 closed defect (fixed)

dojox/mobile/Heading: when href is specified, the back button wrongly uses browser's history instead of opening the file specified by href

Reported by: Adrian Vasiliu Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.9.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

When href is specified for a dojox/mobile/Heading, the back button wrongly does history.back() thus ignoring the href property.

How to reproduce (all desktop and mobile browsers) :

  1. Open a new browser window (to get an empty browser history).
  1. Load for instance http://download.dojotoolkit.org/release-1.9.0b2/dojo-release-1.9.0b2/dojox/mobile/tests/test_transition-animations-extended1.html. This contains a Heading defined as follows:
    <h1 data-dojo-type="dojox.mobile.Heading" 
      data-dojo-props='back:"Top", href:"test_transition-animations.html" ... />
    
  1. Click/touch the back button.

=> the browser navigates to an blank page instead of opening the HTML file specified in href.

This is a regression since 1.8.0. (In 1.7.4 the bug is not present; testable using http://download.dojotoolkit.org/release-1.7.4/dojo-release-1.7.4/dojox/mobile/tests/test_transition-animations-extended1.html which does not exhibit this issue, while it is reproducible with http://download.dojotoolkit.org/release-1.8.0/dojo-release-1.8.0/dojox/mobile/tests/test_transition-animations-extended1.html).

Attachments (1)

patch16991.patch (2.6 KB) - added by Adrian Vasiliu 6 years ago.
Heading with href specified now correctly sets the "back" property of the back button, such that browser's history is no longer wrongly used. Includes DOH test case. - Adrian Vasiliu (IBM, CCLA)

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by Adrian Vasiliu

Attachment: patch16991.patch added

Heading with href specified now correctly sets the "back" property of the back button, such that browser's history is no longer wrongly used. Includes DOH test case. - Adrian Vasiliu (IBM, CCLA)

comment:1 Changed 6 years ago by Adrian Vasiliu

In [31202]:

fixes #16991. Heading with href specified now correctly sets the "back" property of the back button, such that browser's history is no longer wrongly used. Includes DOH test case.

comment:2 Changed 6 years ago by Eric Durocher

Milestone: tbd1.9
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.