Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16972 closed defect (duplicate)

IE9/10: Menu_a11y.html test failure

Reported by: Douglas Hays Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.9.0b2
Keywords: dohfail Cc:
Blocked By: Blocking:

Description (last modified by Douglas Hays)

Load Menu_a11y.hytml in IE9 or 10. There's 1 test failure.
File MenuBarItem should no longer have selected effect, actual class is: dijitReset dijitInline dijitMenuItem dijitMenuItemLabel dijitMenuItemFocused dijitFocused dijitMenuItemSelected
LOG: debug: FAILED test: click 'new' using enter key

Change History (4)

comment:1 Changed 6 years ago by Douglas Hays

Description: modified (diff)
Milestone: tbd1.9

This test passes in 1.8.

comment:2 Changed 6 years ago by bill

Keywords: dohfail added
Resolution: duplicate
Status: newclosed

Duplicate of #16968.
... although I guess it's not clear from the ticket summary.

The root cause is #16970.

comment:3 Changed 6 years ago by bill

In [31152]:

Use IE's native focusin/focusout support for IE9+ too, avoiding asynchronous focus notification, fixes #16968, #16970, and refs #16926, #16972 !strict.

comment:4 Changed 6 years ago by mahays0 <mahays0@…>

In b9ab7f580c8a123ff07ebd9a3b0695e24cf5c5ba/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.