Opened 7 years ago

Closed 4 years ago

#16971 closed defect (fixed)

Build System Error

Reported by: daniel.payne Owned by: Clement Mathieu
Priority: undecided Milestone: 1.11
Component: BuildSystem Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

getting an error building a dojo layer in 1.8.3 and 1.9.0a2

error messages from both

INFO: sanityCheckVars js: "<eval'ed string>#1(Function)#1(eval)", line 129: uncaught JavaScript? runtime exception: TypeError?: Cannot read property "1" from null

at <eval'ed string>#1(Function)#1(eval):129 at <eval'ed string>#1(Function)#1(eval):165 at <eval'ed string>#1(Function)#1(eval):160 at <eval'ed string>#1(Function)#1(eval):216 at <eval'ed string>#1(Function)#1(eval):314 at <eval'ed string>#1(Function)#1(eval):126 at <eval'ed string>#1(Function)#1(eval):177 at <eval'ed string>#1(Function)#1(eval):177 at <eval'ed string>#1(Function)#1(eval):179 at <eval'ed string>#1(Function)#1(eval):179 at <eval'ed string>#1(Function)#1(eval):278 at <eval'ed string>#1(Function)#1(eval):248 (doBuild) at <eval'ed string>#1(Function)#1(eval):283 at <eval'ed string>#1(Function)#1(eval):83

0 error(s), 1 warning(s) js: "<eval'ed string>#1(Function)#1(eval)", line 129: uncaught JavaScript? runtime exception: TypeError?: Cannot read property "1" from null

at <eval'ed string>#1(Function)#1(eval):129 at <eval'ed string>#1(Function)#1(eval):165 at <eval'ed string>#1(Function)#1(eval):160 at <eval'ed string>#1(Function)#1(eval):216 at <eval'ed string>#1(Function)#1(eval):314 at <eval'ed string>#1(Function)#1(eval):127 at <eval'ed string>#1(Function)#1(eval):178 at <eval'ed string>#1(Function)#1(eval):178 at <eval'ed string>#1(Function)#1(eval):180 at <eval'ed string>#1(Function)#1(eval):180 at <eval'ed string>#1(Function)#1(eval):279 at <eval'ed string>#1(Function)#1(eval):249 (doBuild) at <eval'ed string>#1(Function)#1(eval):284 at <eval'ed string>#1(Function)#1(eval):84

It's a complex build - email me at daniel.payne @ keldan.co.uk and I can send you a zip of the project and build profile - i have used both amce and lite selectors

Attachments (2)

eatanddo.profile.js (3.0 KB) - added by daniel.payne 7 years ago.
profile
ValuePickerTimePicker.patch (2.9 KB) - added by bill 7 years ago.
lint fixes

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by daniel.payne

Attachment: eatanddo.profile.js added

profile

comment:1 Changed 7 years ago by bill

Component: GeneralBuildSystem
Owner: set to Rawld Gill

comment:2 Changed 7 years ago by daniel.payne

I have tracked it down a bit more

the error is rased when you build "dojox/mobile/ValuePickerTimePicker" with

layerOptimize: "closure", optimize: "closure"

error does not hapen with

layerOptimize: "shrinksafe", optimize: "shrinksafe"

comment:3 Changed 7 years ago by bill

Owner: changed from Rawld Gill to Ed Chatelain
Status: newassigned

Ed, maybe you should look at this? It sounds like a closure bug but if dojox/mobile/ValuePickerTimePicker is doing something weird it might make sense to change it [so that it doesn't trigger the closure bug].

comment:4 Changed 7 years ago by Ed Chatelain

Owner: changed from Ed Chatelain to Eric Durocher

Eric, I think Bill meant to assign this one to you.

comment:5 Changed 7 years ago by Eric Durocher

I am trying to reproduce, for this I took the attached profile, removed the "ertoc" path and layer, and adapted the paths.

Then using this command in utils/buildscripts (on Windows):

.\build.bat profile=profiles\eatanddo.profile.js

I do get an error but it seems different from what you get:

error(356) The optimizer threw an exception; the module probably contains syntax errors. module iden
tifier: dojocompresed; exception: TypeError: Cannot call method "replace" of undefined

I tried to remove the ValuePickerTimePicker from the profile, but got the same error.

Do you get the same thing if you remove "ertoc" things from the profile too? Do you see these errors with default options, or did you set some debug flag?

I quickly scanned ValuePickerTimePicker for weird things, there are array refs like p[1], a[1] but nothing strange that I can see...

Changed 7 years ago by bill

Attachment: ValuePickerTimePicker.patch added

lint fixes

comment:6 Changed 7 years ago by bill

I see one syntax error in that file plus some unused functions that can be removed. I attached a patch. Not necessarily the cause of the closure crash but good to fix nontheless.

comment:7 Changed 7 years ago by Eric Durocher

OK for the syntax error (missing semi-colon, I'll fix it), but the functions are attribute getters/setters...

I still get the same exception after fixing the syntax error.

comment:8 Changed 7 years ago by bill

Ah, I didn't notice those functions were getters/setters. Too bad the error still happens after fixing the semicolon.

comment:9 Changed 7 years ago by Eric Durocher

In [31206]:

refs #16971. Fix syntax error + lint and api doc issues. Thanks bill.

comment:10 Changed 5 years ago by cjolif

Owner: changed from Eric Durocher to Clement Mathieu

comment:11 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: fixed
Status: assignedclosed

With the fix from 3 years ago listed above, and https://github.com/dojo/dojox/commit/0cb644338f29a1a07eeb10ae5aa216dd79742098 , this builds fine for me without the eatandgo specific modules. If there's still an issue, please let us know.

Note: See TracTickets for help on using tickets.