Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16968 closed defect (fixed)

Menu: focus related problems on IE9+

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.6
Component: Dijit Version: 1.9.0b1
Keywords: Cc:
Blocked By: #16970 Blocking:

Description

On IE9+, when selecting a choice from the menu to close it (ex: select "New" from the "File" menu in test_Menu.html), the "File" choice is marked as selected. That's because the focus() call in _closeChild() is executed asynchronously, after _cleanup() clears the selected item. (This causes a failure in the Menu_a11y.html test.)

There's also presumably a problem when a user defined click handler for a MenuItem shifts focus somewhere else. Menu:_closeChild() shifts focus to the parent MenuBarItem but only if the user defined click handler didn't shift focus somewhere else. However, due to the delay in focus() execution, Menu:_closeChild() will presumably always shift focus back to the MenuBar, defeating the action that the user defined handler did.

Change History (5)

comment:1 Changed 6 years ago by bill

Blocked By: 16970 added
Milestone: tbd1.9
Version: 1.8.31.9.0b1

It turns out this started with [30957] with the root cause of #16970.

comment:2 Changed 6 years ago by bill

#16972 is a duplicate of this ticket.

comment:3 Changed 6 years ago by bill

Resolution: fixed
Status: newclosed

In [31152]:

Use IE's native focusin/focusout support for IE9+ too, avoiding asynchronous focus notification, fixes #16968, #16970, and refs #16926, #16972 !strict.

comment:4 Changed 6 years ago by mahays0 <mahays0@…>

In b9ab7f580c8a123ff07ebd9a3b0695e24cf5c5ba/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 6 years ago by bill

Milestone: 1.91.8.6
Note: See TracTickets for help on using tickets.