Opened 6 years ago

Closed 6 years ago

#16945 closed defect (wontfix)

nested tabContainer with a link inside - broken in IE9 and IE10

Reported by: nhardy Owned by: nhardy
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

When creating a nested (or not nested) tabContainer and placing an <a> tag inside with a javascript void function as the href, the tabContainer displays wierd behaviour. The tab labels disappear, ot change names to true and false (based on the "selected" attribute.

Change History (4)

comment:1 Changed 6 years ago by bill

Owner: changed from bill to nhardy
Status: newpending

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by bill

Resolution: invalid
Status: closedreopened

Changing status to "wontfix".

This was the IE bug where event handlers react to events they shouldn't, as documented in the Weird TabContainer Tabs Title behavior IE9 (Dojo 1.8.1) dojo-interest thread.

In brief, IIRC, the synthetically emitted attrmodified-focus was getting incorrectly caught by a listener for attrmodified-title.

comment:4 Changed 6 years ago by bill

Resolution: wontfix
Status: reopenedclosed

... and the workaround is to stop using

<a href="javascript:void(0)" onclick=...>

and just use

<span onclick=...>
Note: See TracTickets for help on using tickets.