Opened 6 years ago

Closed 6 years ago

#16943 closed defect (invalid)

Tree - Arrow navigation and letter navigation not working - focus not working for dijitTreeRow

Reported by: Adam Skwersky Owned by: Adam Skwersky
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

The arrow keys, while changing the TreeNode? focus, are not adjusting the UI so that you can see the row is in focus (used to be a dotted rectangle). It looks like the dijitTreeRow, while having the 'focused' member set, is not having its DOM class adjusted.

Change History (2)

comment:1 Changed 6 years ago by bill

Owner: changed from bill to Adam Skwersky
Status: newpending

I agree there's no dijitTreeRowFocused class, but I still see the focus border. Which browser is it failing for you on, and what are the exact steps to reproduce the problem using test_Tree.html?

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.