Opened 7 years ago

Closed 7 years ago

#16941 closed defect (duplicate)

Mozilla mobile - don't work scrollable dijits

Reported by: Rombs Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version:
Keywords: Cc:
Blocked By: Blocking:

Description

Hi! I'm use dojox (dojo-1.8.5) in my application. I think I find bag - all dijets with scrolling don't work in Mozilla Mobile (I'm testing on Android devaice Samsung Note II)

I wrote a html page for debugging - its code bellow: <!DOCTYPE html> <html> <head> <title>Touch debug</title> </head> <style> .test{

border: 1px solid; width: 300px; height: 500px; position: relative; left: 50px; background-color: grey;

} </style> <script type="text/javascript">

var dojoConfig = {async: true}

</script> <script type="text/javascript" src="/dojo-1.8.5/dojo/dojo.js"></script> <body>

<script> require(["dojo/_base/window", "dojo/dom", "dojo/dom-construct", "dijit/_WidgetBase", "dojox/mobile/scrollable"], function( win, dom, domConstruct, WidgetBase?, Scrollable){

var widjet = new WidgetBase?(); widjet.placeAt(win.body());

var node = domConstruct.create("div", {className: "test"}); widjet.containerNode = node; widjet.domNode.appendChild(node);

var scrollable = new Scrollable(); scrollable.scrollDir = "h"; scrollable.domNode = widjet.domNode; scrollable.containerNode = node; scrollable.init();

})

</script>

</body> </html>

It's working in desktop version of Mozilla, but does not in mobile version. When I tried to debug with remoute web console I saw this bug: NS_ERROR_XPC_BAD_OP_ON_WN_PROTO: Illegal operation on WrappedNative? prototype object

I patch this bug in file file dojo/on.js:

  1. Add "dojo/_base/lang" in define command
  2. Create new prototype object for class Event

... var tObject = lang.mixin({}, originalEvent) Event.prototype = tObject; var event = new Event; ...

After these all of dijits worked - not smoothly, but work!

  1. S.

I know - my english is not perfect, but I hope this ticket help you to do dojo little better :)

Change History (2)

comment:1 Changed 7 years ago by Rombs

Oh! I found this bug http://bugs.dojotoolkit.org/ticket/16649 (( Sorry

comment:2 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16649.

Note: See TracTickets for help on using tickets.