Opened 7 years ago

Closed 7 years ago

#16936 closed defect (fixed)

demos/touch: the pie chart is invisible in webkit browsers

Reported by: Adrian Vasiliu Owned by: itorrey
Priority: undecided Milestone: 1.9
Component: Website Version: 1.9.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

How to reproduce:

Launch demos/touch/demo.html in webkit browsers (tested on Chrome 25/desktop and Safari mobile iOS 6.x).

=> the pie chart is not visible.

Differently, it shows up on FF19/desktop.

On Chrome, the console shows:

TypeError {info: "Object #<Object> has no method 'byId'"}

Attachments (1)

patch16936.patch (5.5 KB) - added by Adrian Vasiliu 7 years ago.
Fix error thrown in some browsers: use dom.byId instead of dojo.byId - Adrian Vasiliu (IBM, CCLA)

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Adrian Vasiliu

Attachment: patch16936.patch added

Fix error thrown in some browsers: use dom.byId instead of dojo.byId - Adrian Vasiliu (IBM, CCLA)

comment:1 Changed 7 years ago by Adrian Vasiliu

(The attached patch makes the chart visible, but this is not enough to repair entirely demos/touch, because the rotation gesture is broken on iOS6 as side-effect of the latest change in dojo/touch ([31008]). This other issue is treated separately.)

comment:2 Changed 7 years ago by bill

Milestone: tbd1.9

Can you open a ticket for the gesture bug? Or if you have a patch we could just check it in refs #16453.

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [31066]:

moving towards baseless AMD, patch from Adrian Vasiliu (IBM, CCLA), fixes #16936 !strict

Note: See TracTickets for help on using tickets.