Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#16928 closed defect (fixed)

[regression] Editor: first doubleclick opens then closes LinkDialog in IE10

Reported by: haysmark Owned by: bill
Priority: undecided Milestone: 1.8.7
Component: Editor Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Cross reference:

http://download.dojotoolkit.org/release-1.8.3/dojo-release-1.8.3/dijit/tests/editor/test_LinkDialog.html

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/editor/test_LinkDialog.html

In IE10 (on Win8 with touch disabled in my case) in Dojo 1.8.3, double click the link in the first editor. After a few seconds (if you are loading from dojotoolkit.org), a LinkDialog will appear with the properties of the link loaded as expected.

In the nightly Dojo 1.9, try the same thing. After a few seconds, the LinkDialog will briefly flash in and out. If you double click the link in the RTL editor below, you will see the same thing. Subsequent double clicks work as expected.

This failure can also be reproduced with the robot test; see "Double-Click opens TooltipDialog".

Change History (7)

comment:1 Changed 6 years ago by haysmark

Milestone: tbd1.9

comment:2 Changed 6 years ago by bill

Description: modified (diff)
Owner: set to bill
Status: newassigned
Summary: regression: Editor with LinkDialog closes dialog in IE10[regression] Editor: first doubleclick opens then closes LinkDialog in IE10

I see it. Not such a bad problem since it only happens on the first doubleclick, but still a slight regression. It's from my [30957] change so I'll take a look.

comment:3 Changed 6 years ago by bill

On the first double click, the focusout event on the dijitEditorBody (the <body> node inside the editor's <iframe>) occurs *after* the focusin event on the <input> in the dialog (editor_0_urlinput).

comment:4 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [31074]:

Avoid problem on IE9+ where the link dialog opens then closes immediately the first time a link is double clicked. It stems from a problem on IE9+ where the focusout event on the <iframe> comes after the focusin event on the <input> in the link dialog. Fixes #16928 !strict.

comment:5 Changed 5 years ago by Bill Keese <bill@…>

In 841aea491981fbeaafa5a5ba075cb07fe1f07548/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 5 years ago by bill

Milestone: 1.91.8.7

comment:7 Changed 5 years ago by bill

(Note: I'm backporting this change for safety, not sure if it's needed or not.)

Note: See TracTickets for help on using tickets.