Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16920 closed defect (fixed)

In Opener, calendar days not readable on Samsung Galxy SIII with Holodark theme

Reported by: Sebastien Brunot Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description

When displayed in an Opener (like in the test page dojox/mobile/tests/test_opener-Calendar-lazy-prog.html), the days displayed on a dijit calendar are not easily readable (because they are displayed black on a black background). This has been reproduced using a Samsung Galaxy SIII on Android 4.0.3 and on Android 4.1.2.

Attachments (2)

ticket16920.patch (882 bytes) - added by Sebastien Brunot 6 years ago.
Fix the color of dijit calendar days on an icon item panel when using the Holodark theme (IBM CCLA).
ticket16920-2.patch (1.7 KB) - added by Sebastien Brunot 6 years ago.
Fix the color of dijit calendar days on an icon item panel when using the Holodark theme, but without impact on the original dijit calendar themes (claro, tundra, ...). (IBM CCLA°.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by Sebastien Brunot

CORRECTION: The problem is visible in the test page dojox/mobile/tests/test_IconContainer-single.html, whereas it's ok in test page dojox/mobile/tests/test_opener-Calendar-lazy-prog.html.

Changed 6 years ago by Sebastien Brunot

Attachment: ticket16920.patch added

Fix the color of dijit calendar days on an icon item panel when using the Holodark theme (IBM CCLA).

comment:2 Changed 6 years ago by cjolif

Resolution: fixed
Status: newclosed

In [31111]:

fixes #16920. Fix the color of dijit calendar days on an icon item panel when using the Holodark theme. Thanks Sebastien Brunot (IBM CCLA).

comment:3 Changed 6 years ago by cjolif

Milestone: tbd1.9

Changed 6 years ago by Sebastien Brunot

Attachment: ticket16920-2.patch added

Fix the color of dijit calendar days on an icon item panel when using the Holodark theme, but without impact on the original dijit calendar themes (claro, tundra, ...). (IBM CCLA°.

comment:4 Changed 6 years ago by Sebastien Brunot

The location of the first patch had an impact on the calendar when used with a dijit themes (claro, tundra, ...), as can be seen in the test page dojox/mobile/tests/test_dynamic-icons.html.

I've attached a second patch that solves the problem but doesn't have any impact when using a calendar with a dijit theme.

comment:5 Changed 6 years ago by cjolif

In [31147]:

refs #16920. Fix the color of dijit calendar days on an icon item panel when using the Holodark theme, but without impact on the original dijit calendar themes (claro, ...). Thanks Sebastien Brunot (IBM CCLA)

Note: See TracTickets for help on using tickets.