Opened 7 years ago

Closed 7 years ago

#16906 closed defect (invalid)

dojox/mobile/parser ie8 input type bug

Reported by: superdweebie Owned by: superdweebie
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

I'm using the dojox/mobile/parser because is it much smaller than the standard dojo/parser, as suggested in the docs. However, ie8 will throw an error on any attempt to set the type attribute on an input tag, which the parser does attempt to do. It seems to be a simple fix. Change line 58 from:

if(!v && (t !== "boolean"
v !== "")){ continue; }

to:

if((!v && (t !== "boolean"
v !== "")) prop == 'type'){ continue; }

Change History (4)

comment:1 Changed 7 years ago by Adrian Vasiliu

I have unsuccessfully tried to reproduce. I have tried in IE8 from both Dojo 1.8.3 and current trunk with dojox/mobile/tests/test_ComboBox-sv.html (which contains <input type="text" data-dojo-type="dojox.mobile.ComboBox" ...>), and by modifying tests/test_FormControl.html to add a type attribute to the <input data-dojo-type="dojox.mobile.SearchBox" ...>. Both tests use the mobile parser, however I did not get any error. I didn't get an error with <input type="text"> either.

Could you submit a runnable test case to reproduce?

Also, the code that you suggested:

if((!v && (t !== "boolean"
v !== "")) 	prop == 'type'){ continue; } 

is syntactically not correct, I guess it was corrupted during copy-paste.

comment:2 Changed 7 years ago by Adrian Vasiliu

Owner: changed from Eric Durocher to superdweebie
Status: newpending

comment:3 Changed 7 years ago by Adrian Vasiliu

So we are still awaiting for your answer, otherwise hope you'll understand that we'll close the ticket.

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.