Opened 7 years ago

Closed 6 years ago

#16879 closed defect (fixed)

IE10: Animated chart plots do not consistently render.

Reported by: Jared Jurkiewicz Owned by: Patrick Ruzand
Priority: undecided Milestone: 1.9
Component: DojoX GFX Version: 1.8.3
Keywords: ie10 Cc:
Blocked By: Blocking:

Description (last modified by Jared Jurkiewicz)

This appears to be an IE10 rendering bug where it doesn't always invalidate and update the render box containing the SVG elements of the chart. It is intermittently reproducible with the test_anim2d.html testcase for charting. With more complex charts/lots of datapoints, it becomes consistently reproducible.

When the issue triggers, the chart appears empty/blank.

I found a way to work around it by modifying the dojox.fx animateTransform code to prod the containing node on each animation tick to force a redraw. Patch coming shortly to work around the IE10 issue.

Attachments (3)

16879.patch (2.4 KB) - added by Jared Jurkiewicz 7 years ago.
Possible patch for this issue.
test_fx_group.html (1.3 KB) - added by cjolif 7 years ago.
test case that reproduces the issue
16879.2.patch (2.0 KB) - added by Patrick Ruzand 6 years ago.
updated patch

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Jared Jurkiewicz

Description: modified (diff)

comment:2 Changed 7 years ago by Jared Jurkiewicz

Description: modified (diff)

Changed 7 years ago by Jared Jurkiewicz

Attachment: 16879.patch added

Possible patch for this issue.

comment:3 Changed 7 years ago by Patrick Ruzand

Owner: changed from Eugene Lazutkin to Patrick Ruzand
Status: newassigned

Changed 7 years ago by cjolif

Attachment: test_fx_group.html added

test case that reproduces the issue

comment:4 Changed 7 years ago by cjolif

Keywords: ie10 added

comment:5 Changed 6 years ago by Patrick Ruzand

Seems to be specific to the SVG renderer.

Changed 6 years ago by Patrick Ruzand

Attachment: 16879.2.patch added

updated patch

comment:6 Changed 6 years ago by Patrick Ruzand

Milestone: tbd1.9

jaredj, I have slightly modified your patch wrt to the way you walk up to the surface container: in gfx the surface is the first parent that does not define a getParent method.
Do you have some particular configurations that would change this behavior ? Could you test it and tell me if it's ok in your app/use case ?

comment:7 Changed 6 years ago by Patrick Ruzand

reproduced also with dojox/charting/tests/test_win2d.html.

comment:8 Changed 6 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

In [31256]:

workaround IE10 refresh issue during animation, thx jaredj, fixes #16879 !strict

Note: See TracTickets for help on using tickets.