Opened 7 years ago

Closed 7 years ago

#16869 closed defect (invalid)

Opener does not close on touch event

Reported by: slizeray Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description

The opener closes when one clicks outside but with a touch screen the opener does not close on a touch event outside of the widget

Change History (5)

comment:1 Changed 7 years ago by slizeray

This is about the dojos..mobile.Opener, I forgot to specify the component

comment:2 Changed 7 years ago by bill

Component: GeneralDojoX Mobile
Owner: set to Eric Durocher

comment:3 Changed 7 years ago by Eric Durocher

The Opener has a different behavior on phones (where it is a subclass of Overlay and slides up from the bottom of the screen) and on tablets/desktop (where it is a Tooltip). The opener will hide on clicks only in Tooltip mode, not in Overlay mode.

So, just to be clear, do you see a difference between mouse and touch in the same mode (i.e. click+Overlay / touch+Overlay or click+Tooltip / touch+Tooltip)? Or, do you test for example on desktop, where you get a tooltip and where clicking will hide the tooltip, and then on a phone where you get an Overlay and no auto-hide?

comment:4 Changed 7 years ago by dg

After some investigations this issue was caused by another code that is independent of dojox mobile. This defect can be closed. Thanks, Damien

comment:5 Changed 7 years ago by Eric Durocher

Resolution: invalid
Status: newclosed

OK thanks for the update.

Note: See TracTickets for help on using tickets.