Opened 7 years ago

Closed 7 years ago

#16866 closed defect (fixed)

Click events emitted on disabled buttons on touch devices

Reported by: Sebastien Brunot Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.9.0a2
Keywords: Cc: bill
Blocked By: Blocking:

Description

On blackberry 10, click events are emitted on disabled buttons. It can be reproduced using the test page dojox/mobile/tests/test_Button.html: when the disabled button is clicket, its click event handler is executed and the following message is displayed in the page: "Disabled" button was clicked.

Attachments (2)

ticket16866.patch (461 bytes) - added by Sebastien Brunot 7 years ago.
This patch disable the emission of click events on disabled elements (IBM CCLA).
touch_click_disabled.patch (574 bytes) - added by Eric Durocher 7 years ago.
Don't send synthetic clicks on disabled elements - Eric Durocher (IBM, CCLA)

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Sebastien Brunot

Attachment: ticket16866.patch added

This patch disable the emission of click events on disabled elements (IBM CCLA).

comment:1 Changed 7 years ago by Eric Durocher

Better to test disabled on the origin node.

comment:2 Changed 7 years ago by Eric Durocher

Cc: bill added
Milestone: tbd1.9
Summary: Blackberry 10: Click events emitted on disabled buttonsClick events emitted on disabled buttons on touch devices

Note the problem occurs on all touch devices, not only BlackBerry 10, so I update the summary (for some reason I can't edit the description...)

Changed 7 years ago by Eric Durocher

Attachment: touch_click_disabled.patch added

Don't send synthetic clicks on disabled elements - Eric Durocher (IBM, CCLA)

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [30902]:

Don't generate click events due to touchstart/touchend on disabled <button> nodes. Fixes #16866, refs #15878 !strict. Also renamed "clicked" to "clickTracker".

Note: See TracTickets for help on using tickets.