Opened 6 years ago

Closed 6 years ago

#16858 closed defect (fixed)

REGRESSION: dojox.widget.Standby throws errors if you target body.

Reported by: Jared Jurkiewicz Owned by: dante
Priority: undecided Milestone: 1.9
Component: DojoX Widgets Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

If you target dojo.body() then standby throws errors on show when it tries to check its parent (and its parent zIndex, which is document).

This appears to be due to AMD changes and logic that did testing to try and look at the containment node. Simple patch forthcoming.

Attachments (1)

16858.patch (540 bytes) - added by Jared Jurkiewicz 6 years ago.
Simple patch for this to not bother with checking cNode if target was body.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by Jared Jurkiewicz

Milestone: tbd1.9

Changed 6 years ago by Jared Jurkiewicz

Attachment: 16858.patch added

Simple patch for this to not bother with checking cNode if target was body.

comment:2 Changed 6 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

In [30871]:

Minor fix to Standby containment checking. fixes #16858

Note: See TracTickets for help on using tickets.