Opened 7 years ago

Closed 7 years ago

#16846 closed defect (duplicate)

On a tablet ths showing of virtual keyboard causes a "/dojox/mobile/screenSize/phone"

Reported by: daniel.payne Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

On a tablet ths showing of virtual keyboard causes a "/dojox/mobile/screenSize/phone" message to be emitted which causes the app to change layout in screenSizeAware mode

replicate with "http://keldan.org.uk/dojo/test001.html", use a tablet and select a text field

OR

http://download.dojotoolkit.org/release-1.7.1/dojo-release-1.7.1/dojox/mobile/tests/test_screen-size-aware-demo.html in a wide screen window, drag the bottom border up to simulate the keypad opening


this is caused in common.js

dm.detectScreenSize() ... var sz = Math.min(dim.w, dim.h); ...

replacing with Math.max fixes the problem - but i don't know the side effects

Change History (2)

comment:1 Changed 7 years ago by bill

Component: GeneralDojoX Mobile
Owner: set to Eric Durocher

comment:2 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16845.

Note: See TracTickets for help on using tickets.