Opened 7 years ago

Closed 7 years ago

#16839 closed defect (fixed)

[regression] Tree: error when clicking above/below TreeNodes

Reported by: spaquette Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Looks like this started after [30808]. If you place a Tree inside a ContentPane whose size is larger than the Tree needs, there can be extra space above/below the Tree. If you click in this space in 1.9.0a2 or 1.8, there's no error, but starting after [30808], there's this:

Uncaught TypeError: Cannot read property 'id' of null (_dndSelector.js:199)

(My test example needs a copy of trunk to show the bug.)

Attachments (1)

tree_contentPane_test.html (3.3 KB) - added by spaquette 7 years ago.
Example of Tree-in-ContentPane? clicking bug

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by spaquette

Attachment: tree_contentPane_test.html added

Example of Tree-in-ContentPane? clicking bug

comment:1 Changed 7 years ago by spaquette

The problem might be this at _dndSelector.js:190:

if(this.current && this.tree.isExpandoNode(e.target, this.current)){ return; }

It was this previously:

if(!this.current || this.tree.isExpandoNode(e.target, this.current)){ return; }

If I revert that the error stops, maybe because the previous version was also catching and ignoring clicks outside the Tree's rows that still landed on the Tree's DIV, but the current version doesn't.

comment:2 Changed 7 years ago by bill

Milestone: tbd1.9
Status: newassigned

I see, makes sense, thanks.

comment:3 Changed 7 years ago by bill

Description: modified (diff)
Summary: [regression] Error when clicking above/below a Tree in a ContentPane[regression] Tree: error when clicking above/below TreeNodes

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30852]:

avoid exception when clicking on the Tree itself rather than a row in the tree, fixes #16839 !strict

Note: See TracTickets for help on using tickets.