Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16824 closed feature (fixed)

a11yclick: new press and release events

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Add synthetic events "press" and "release" to dijit/a11yclick that fire for mousedown/mouseup, touchstart/touchend (or Microsoft equivalents), or keydown/keyup. They only call the listener when the events will trigger a click. I.E. for keyboard, it's the SPACE or ENTER key, and for mouse, it's the left mouse button.

This can be useful to multiple modules:

  • _HasDropDown
  • tree/_dndSelector
  • _CssStateMixin

Change History (3)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9
Status: newassigned

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

Actually this is already fixed, but I figured it should have it's own ticket.

[30807] created the new synthetic events and updated _CssStateMixin to use them.

[30808] updated tree/_dndSelector to use the new events.

comment:3 Changed 7 years ago by bill

PS: I decided not to use it for _HasDropDown. The handling there is (by design) different for mouse vs. keyboard, because on mouse the mousedown opens the menu, but on keyboard it waits for the mouseup.

Note: See TracTickets for help on using tickets.