Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#16821 closed defect (worksforme)

ComboBox not clickable on Firefox 19.0.2 and Windows 8

Reported by: alakeetm Owned by: alakeetm
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

I can't select a combobox item using the mouse. This problem also applies to range slider. I can't slide using the mouse. I'm using fire Fox 19.0.2 on Windows 8. I have uninstalled and reinstalled Firefox and disabled all the addons with no lock. I found an earlier bug record with status closed (worksforme), I guess this is a real bug and needs to be fixed.

Change History (13)

comment:1 Changed 7 years ago by alakeetm

I just tested comboBox on Chrome Version 25.0.1364.152 m and comboBox still not clickable or item not selectable. IE version 10 works fine.

comment:2 Changed 7 years ago by bill

Owner: changed from Douglas Hays to alakeetm
Status: newpending

Works for me, both on trunk and the 1.8 branch, tested on first ComboBox in test_ComboBox.html.

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.)

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:3 Changed 7 years ago by dgaj

This is happening to me as well but for FilteringSelect? too. No browser on Windows 8 works. Windows 7 and XP work fine.

comment:4 Changed 7 years ago by dgaj

Correction the only browser it DOES work on Windows 8 is IE.

comment:5 Changed 7 years ago by bill

Like I said http://download.dojotoolkit.org/release-1.8.3/dojo-release-1.8.3/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox is working for me on FF19 on Win8. If you have a test case that fails you'll need to attach it.

comment:6 Changed 7 years ago by alakeetm

Status: pendingnew

I created another test page and tested ComboBox? and worked fine on both Firefox and Chrome. the problem is happening on my PC only in the test page dijit/test/form/_autoComplete.html?testWidget=dijit.form.ComboBox?. I guess at this point you can close the ticket.

comment:7 Changed 7 years ago by bill

Resolution: worksforme
Status: newclosed

OK, I'll close. It's strange that dijit/test/form/_autoComplete.html?testWidget=dijit.form.ComboBox? fails for you because it's working for me. If we figure out why it's failing on your system let's reopen.

comment:8 Changed 6 years ago by alessior

I have the same problem: mouse click on Combobox DOESN'T work when i try to select a item. The page http://download.dojotoolkit.org/release-1.8.3/dojo-release-1.8.3/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox DOESN'T work with Win7 and Firefox 20.0.1 or Chrome 26.0.1410.64 but works fine with IE10

comment:9 Changed 6 years ago by bill

Not sure what to tell you. I tried that URL on Windows7 on both FF and Chrome and it works fine for me.

comment:10 Changed 6 years ago by RGB

I just registered to say that i also have this bug. As allready said it doesn't work in Firefox 20.0.1 or Chrome 26.0.1410.64 (the newest versions). But i have older versions for development and it works in: Chrome 16.0.912.77 Opera 11.61 IE 10 So it is important the test with the versions that are not working. I have Windows 7 SP1 and it doesn't work in my page i am developing and http://download.dojotoolkit.org/release-1.8.3/dojo-release-1.8.3/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox

Last edited 6 years ago by RGB (previous) (diff)

comment:11 Changed 6 years ago by Alexander Kläser

Just for the records, we also had customers reporting this problem using Windows 7 (latest updates) with Chrome 26 (latest updates). I could not reproduce this problem myself using a virtual Windows instance. I am also not sure so far whether the problem persists with Dojo 1.8.3, I only know that it occurred with Dojo 1.8.0. See also our bug report:

https://forge.univention.org/bugzilla/show_bug.cgi?id=30712

comment:12 Changed 6 years ago by RGB

I'm using Dojo 1.8.3. But i saw a link to the nighty test website and it works! http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox

Don't know what changed but it works in Chrome and Firefox with this version. Hope the version is stable soon ;)

comment:13 Changed 6 years ago by bill

It is stable: 1.9.0 was released about a week ago.

Note: See TracTickets for help on using tickets.