Opened 6 years ago

Closed 6 years ago

#16818 closed defect (fixed)

Build system throws memory error when \ used in releaseDir path

Reported by: kbenjamin Owned by: Rawld Gill
Priority: undecided Milestone: 1.9
Component: BuildSystem Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

When building under Windows and using the releaseDir option the build system throws fatal Java out of heap or out of memory errors during writeResources.

The problem is described here: http://stackoverflow.com/questions/11148947/dojo-1-7-build-out-of-memory-errors, as is the workaround.

The problem occurs when a Windows-style path is specified i.e. path\to\release\dir but does not fail when a Unix-style path is specified i.e. path/to/release/dir.

This seems specific to the releaseDir property as other paths seem to to work correctly.

Change History (2)

comment:1 Changed 6 years ago by Rawld Gill

Milestone: tbd1.9
Status: newassigned

comment:2 Changed 6 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [31253]:

fix improper processing of backslashes on when used with command line arguments; fixes #16818; !strict

Note: See TracTickets for help on using tickets.