Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#16804 closed task (fixed)

set DOCTYPE on iframe

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.7.6
Component: Editor Version: 1.8.3
Keywords: Cc: Jared Jurkiewicz
Blocked By: Blocking:

Description

The editor's iframe doesn't set a DOCTYPE so apparently it's running in quirksmode. Try adding a DOCTYPE.

See also #14900, although it's probably unrelated because it's about the opposite problem.

Change History (14)

comment:1 Changed 7 years ago by bill

Cc: Jared Jurkiewicz added
Milestone: tbdfuture

comment:2 Changed 7 years ago by bill

Milestone: future1.9
Owner: set to bill
Status: newassigned

I tried it and it seems to work fine.

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30951]:

add doctype on editor's iframe, fixes #16804 !strict

comment:4 Changed 7 years ago by bill

In [30953]:

Removing parts of ToggleDir test that fail after switching editor iframe to standards mode. They were depending on behavior of down arrow and right arrow that isn't guaranteed. Plus, the tests didn't seem very useful (beyond just checking the dir setting on the iframe). Refs #16804.

comment:5 Changed 7 years ago by bill

In [30955]:

Tweak inSelection() to work on IE8 for standards mode document. For range.compareEndPoints("EndToStart?", newRange"), newRange must be a text range, not a control range. This fixes the failure in FontChoice test after switching the editor iframe to standards mode. Refs #16804.

comment:6 Changed 7 years ago by bill

Resolution: fixed
Status: closedreopened

Hmm, [30951] actually broke the editor tests. when robot/EnterKeyHandling.html starts running and clicks the first editor, IE8 actually goes back to the previous page (like you hit the browser's "back" button). The test failure doesn't show up in the log because it just runs the custom plugin test again. Still, something is wrong.

The problem is that clicking the editor (in the center, below the visible text) doesn't actually focus the editor, so the backspace key gets processed by the browser.

comment:7 Changed 7 years ago by bill

Resolution: fixed
Status: reopenedclosed

In [31303]:

Make <body> height 100%, so that clicking anywhere on the editor window focuses it on IE8. As a side effect, the scroll bar needs to go on the <body> rather than on <html>. Tested on IE8, Chrome, FF (manually), and IE9. Fixes #16804 !strict.

comment:8 Changed 6 years ago by Bill Keese <bill@…>

In d3d7755e7d3d2135dcedcc51cc16f7431a065d5d/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 6 years ago by Bill Keese <bill@…>

In fbfc0fe89385b8c85f2ae75c27a15ac807b42e71/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 6 years ago by mahays0 <mahays0@…>

In 162b535bcccb4711e036c7cdf5dfea23f412dc5a/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 6 years ago by mahays0 <mahays0@…>

In c77d355c71583e6cea314a1d1058bc791407bf27/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:12 Changed 5 years ago by Bill Keese <bill@…>

In 337f3797e7c1e686e0f37157ac4e69cd8da2a019/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:13 Changed 5 years ago by Bill Keese <bill@…>

In 8d4762e5b76be5e508f7468b0bd03172f6843185/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:14 Changed 5 years ago by bill

Milestone: 1.91.7.6
Note: See TracTickets for help on using tickets.