Opened 6 years ago

Closed 6 years ago

#16777 closed defect (duplicate)

Internet Exploder Column Chart axis label Rendering issue

Reported by: Naris Owned by: Eugene Lazutkin
Priority: undecided Milestone: tbd
Component: Charting Version: 1.9.0a2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by cjolif)

I have a page with several charts containing StackedColumns? & grid plots and axis labels. These render well in Firefox and Chrome, but the axis labels are missing or possible truncated in Internet Exploder (I am using IE 8.0).

However, there is another chart that also has a couple of line plots in addition to the StackedColumn? chart and in that one the axis labels are rendered correctly in Internet Exploder.

I have confirmed that this happens with both dojo versions 1.8.3 & 1.9.0a2.

I have attached sample images from IE 8.0 & Firefox along with the javascript used to create the charts.

Attachments (13)

FF-StackedColumnChart.png (23.1 KB) - added by Naris 6 years ago.
IE-StackedColumnChart.png (20.5 KB) - added by Naris 6 years ago.
FF-StackedColumnWithLinesChart.png (43.7 KB) - added by Naris 6 years ago.
IE-StackedColumnWithLinesChart.png (36.7 KB) - added by Naris 6 years ago.
chart.html (23.1 KB) - added by Naris 6 years ago.
Source Code
test.html (13.2 KB) - added by naris 6 years ago.
test chart which is completely broken in IE only
test2.html (12.7 KB) - added by naris 6 years ago.
Test chart that work in all browsers with charts in the body.
test3.html (7.8 KB) - added by naris 6 years ago.
Test of single chart that is empty in IE and works in other browsers
IE-test.PNG (20.0 KB) - added by naris 6 years ago.
Image of test.html in IE
FF-test.PNG (40.5 KB) - added by naris 6 years ago.
Image of test.html in FireFox?
IE-test3.PNG (10.8 KB) - added by naris 6 years ago.
Image of test3.html in IE
FF-test3.PNG (18.2 KB) - added by naris 6 years ago.
Image of test3.html in FireFox?
vwUsaChart.html (8.9 KB) - added by naris 6 years ago.

Download all attachments as: .zip

Change History (21)

Changed 6 years ago by Naris

Attachment: FF-StackedColumnChart.png added

Changed 6 years ago by Naris

Attachment: IE-StackedColumnChart.png added

Changed 6 years ago by Naris

Changed 6 years ago by Naris

Changed 6 years ago by Naris

Attachment: chart.html added

Source Code

comment:1 Changed 6 years ago by naris

Correction, I am using IE 8.0, not 9.0

comment:2 Changed 6 years ago by cjolif

Description: modified (diff)

comment:3 Changed 6 years ago by cjolif

Unfortunately your example does not run as-is as it requires some data server. In order to accelerate us looking into this issue would you mind creating a sample:

1/ that do not rely on external data (just embed dummy data in your sample)

2/ that is minimal (i.e. does not contain other code like grid for example)

comment:4 Changed 6 years ago by naris

I have created test versions of the original page and have stumbled into other issues. test.html and test3.html work OK in FireFox? and Chrome, but yield empty charts in IE. test2.html works in all browser, the difference seems to be that the original chart.html, test.html & test3.html all embed the charts in an Accoridan while test2.html does not (they are in the root/body node.

Changed 6 years ago by naris

Attachment: test.html added

test chart which is completely broken in IE only

Changed 6 years ago by naris

Attachment: test2.html added

Test chart that work in all browsers with charts in the body.

Changed 6 years ago by naris

Attachment: test3.html added

Test of single chart that is empty in IE and works in other browsers

Changed 6 years ago by naris

Attachment: IE-test.PNG added

Image of test.html in IE

Changed 6 years ago by naris

Attachment: FF-test.PNG added

Image of test.html in FireFox?

Changed 6 years ago by naris

Attachment: IE-test3.PNG added

Image of test3.html in IE

Changed 6 years ago by naris

Attachment: FF-test3.PNG added

Image of test3.html in FireFox?

comment:5 Changed 6 years ago by cjolif

I suspect this might be related to : http://trac.dojotoolkit.org/ticket/9935#comment:10 (not sure). Have you tried the listed workaround? Note that using IE9 should fix the problem as well as IE9 will use SVG not VML.

comment:6 Changed 6 years ago by naris

I started to make an IE version of the page to use the workaround from ticket 9935 (by using iframes for the charts).

I found that when I separated out the charts into their own .html files the original issue I reported (where the axis labels are not rendered in IE) happened only when the store is a JsonRest?() store. If I replaces the JsonRest? store with a Memory store, then the labels did render (even when the chart is in the "root" node).

comment:7 Changed 6 years ago by naris

I am no longer able to attach files to posts, it thinks they are spams and expects me to type captcha images that either I can't see or it won't accept the correct answer to since it always rejects whatever I enter. Therefore, I will paste the script here:

Correction: It finally allowed me to upload a file without having to enter an impossible captcha code.

Last edited 6 years ago by naris (previous) (diff)

Changed 6 years ago by naris

Attachment: vwUsaChart.html added

comment:8 Changed 6 years ago by cjolif

Resolution: duplicate
Status: newclosed

So if embedding in iframe (separate html) solves the problem for MemoryStore this is definitely a duplicate of #9935. The JsonRestStore issue seems to be different I suppose. Please open a separate ticket for that one including a data set example you are reading from your JsonRestStore? so that it can be reproduced.

Note: See TracTickets for help on using tickets.