Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16765 closed defect (duplicate)

Issues on Chrome 25 / Win 7 : filtering select and sliders

Reported by: babynus Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

New issues has come with Chrome 25, on Win 7.

  • Filtering Select : cannot select item in list with mouse
  • Sliders between contentpanes : cannot be dragged to resize panes.

It can be reproduced in easily : http://dojotoolkit.org/reference-guide/1.8/dijit/layout/BorderContainer.html#dijit-layout-bordercontainer http://dojotoolkit.org/reference-guide/1.8/dijit/form/FilteringSelect.html#dijit-form-filteringselect Just run examples...

I reproduced this behavior with V1.8.3 and V1.7.2.

Issues are not reproduced with Chrome 25 on XP. Issues were not reproduced with Chrome 24 on XP. Only Chrome 25 on Win7 seems to bring issues.

Change History (11)

comment:1 Changed 7 years ago by babynus

Issues were not reproduced with Chrome 24 on Win7

comment:2 Changed 7 years ago by babynus

comment:3 Changed 7 years ago by Douglas Hays

I'm running Chrome 25 on Win 7 and it's working perfectly. Try:
http://download.dojotoolkit.org/release-1.8.3/dojo-release-1.8.3/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect
to make sure it's not just your source tree.

comment:4 Changed 7 years ago by babynus

I just tried proposed link :

  • I can set values using buttons : OK
  • If I open the drop list, and try to select an item in the list : Click has no effect, on change is not triggered.

My Chrome version is : 25.0.1364.97 m My Windows version is : Windows 7 Edition Familiale Premium (Fr) Service Pack 1

comment:5 Changed 7 years ago by babynus

I tried to remove all extensions and disable all plugins : still not working.

Any idea ?

comment:6 Changed 7 years ago by haysmark

I can't reproduce the issue either. Are you running any kind of IME or touch support in the background? Maybe some external program is conflicting with the mouse events.

comment:7 Changed 7 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

My Chrome version is also 25.0.1364.97 with the OS being Windows 7 Professional (US). Sounds like a system software conflict.

comment:8 Changed 7 years ago by bill

Resolution: worksforme
Status: closedreopened

It must be that you have a touch screen, and are hitting #13048, fixed in (the as-yet-unreleased) 1.8.4.

Or alternately you have the "emulate touch screen" checkbox checked in the developer console, but I don't think that checkbox is there anymore in chrome 25.

comment:9 Changed 7 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Duplicate of #13048.

comment:10 Changed 7 years ago by babynus

Hi,

I don't have any "touch screen" emulation (or at least don't know I have some). Problem also occurs with no other program running (or at least none in foreground).

I'll have a further look to find if I can get any "touch screen" option off. I'll also test V1.8.4 when it is deployed.

Many thanks for your suggestions.

comment:11 Changed 7 years ago by babynus

Hi,

You were right : it was some "touch screen" issue.

I had some old "Tablet" driver. I removed it, and all is working fine now !

Many thanks for your help

Note: See TracTickets for help on using tickets.