Opened 6 years ago

Closed 6 years ago

#16750 closed defect (invalid)

DAP violation Label For attribute does not reference an appropriate form control

Reported by: myu1 Owned by: myu1
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.6.1
Keywords: Cc: mikeb
Blocked By: Blocking:

Description

I am using FF10 and Dojo 1.6.1. I ran Dynamic Assessment Plugin on a page and got the violation Label For attribute does not reference an appropriate form control. I think the form control is valid. Is this a false violation due to Dojo 1.6.1?

Change History (3)

comment:1 Changed 6 years ago by bill

Cc: mikeb added
Component: GeneralAccessibility
Owner: set to myu1
Status: newpending

It's likely either a bug in your page, or something that was fixed in Dojo 1.8, but impossible to tell since you haven't attached a test case or given any instructions on how to reproduce the problem.

If it still happens in Dojo 1.8 then you'll need to give instructions on how to reproduce the problem, including attaching a test case or referencing an existing (public) test case.

comment:2 Changed 6 years ago by mikeb

It is possible that the for="" attribute does not map to any ID on the page. Ensure that your form control's ID field is exactly the same as the "for" value in the <label>. Also, what is the form control? I know that DAP is bugged for dijit.Select....

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.