Opened 6 years ago

Closed 6 years ago

#16749 closed defect (invalid)

DAP violation Provide descriptive text in label elements

Reported by: myu1 Owned by: myu1
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.6.1
Keywords: Cc: mikeb
Blocked By: Blocking:

Description

I am using FF10 and Dojo 1.6.1. I ran Dynamic Assessment Plugin on a page and got the violation Provide descriptive text in label elements. In the label element, I have a container which includes a text box. Is this a false violation due to Dojo 1.6.1?

Change History (4)

comment:1 Changed 6 years ago by bill

Component: GeneralAccessibility
Owner: set to myu1
Status: newpending

It's likely either a bug in your page, or something that was fixed in Dojo 1.8, but impossible to tell since you haven't attached a test case or given any instructions on how to reproduce the problem.

If it still happens in Dojo 1.8 then you'll need to give instructions on how to reproduce the problem, including attaching a test case or referencing an existing (public) test case.

comment:2 Changed 6 years ago by bill

Cc: mikeb added

comment:3 Changed 6 years ago by mikeb

I have never heard of putting a text box inside of a label. Try to remove the textbox and put just text in the label and see if there is a problem. Alternatively you could try using the "aria-label" attribute on the form (instead of using a <label> at all). If you want to keep the text box, maybe you could put an "aria-label" on the textbox object. I don't think this can be a bug in Dojo because we don't create any labels containing textboxes (or anything other than text.)

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.