Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#16733 closed defect (wontfix)

Superfluous comma in datetimeformat-short (cldr/nls/en/gregorian.js)

Reported by: wol Owned by: Adam Peller
Priority: undecided Milestone: tbd
Component: Date Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

In cldr/nls/en/gregorian.js, datetimeformat-short is defined as follows:

"dateTimeFormat-short": "{1}, {0}"

The comma after the {1} is new, introduced with


r30140 | peller | 2012-12-07 23:07:01 +0100 (Fre, 07. Dez 2012) | 176 Zeilen

run scripts against CLDR v21 Refs #13906, #15424, #16281 -This line, and those below, will be ignored--

We have a custom textbox widget, and in the end, datetimeformat-short is used by _parseInfo in dojo/date/locale.js to assemble a complete datetime pattern based on (1) a date pattern and (2) a time pattern.

E.g. we have dd.MM.yyyy and hh:mm, and the expected result is "dd.MM.yyyy hh:mm", however since r30140, the result is "dd.MM.yyyy, hh:mm" which obviously is not the desired result.

In language files like de/gregorian.js, that comma is not present, just our code uses the en/gregorian.js language file.

Change History (5)

comment:1 Changed 7 years ago by Adam Peller

This was apparently a deliberate change made by the CLDR maintainers

comment:2 Changed 7 years ago by sasdxm

I got caught by this also. Seems like it would be really useful to be able to specify the separation character for user defined date/time formatting and parsing.

comment:3 Changed 6 years ago by Adam Peller

#17342 is a duplicate of this ticket.

comment:4 Changed 6 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

comment:5 Changed 6 years ago by vapier

i've filed #17544 to add an enhancement to make this possible (it also includes a simple hack for people working with the current code base)

Note: See TracTickets for help on using tickets.