Opened 6 years ago

Closed 6 years ago

#16732 closed defect (invalid)

Got "ID values must be unique" DAP violation

Reported by: myu1 Owned by: myu1
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

I am using FF10 and Dojo 1.6.1. The id I used is unique for the page. Could this be an issue with Dojo 1.6.1 only?

<label for="_00000000-0000-0000-0000-000000000000-0_RetentionDate_Radio1_folder.step.Document.Retention.HEAD">None&nbsp;<img tabindex="0" style="vertical-align: top;" title="Help for None" alt="Help for None" src="/navigator/plugin/AccePlugin/getResource/acce/css/images/types/Help12.png" id="imgtooltip00000000-0000-0000-0000-000000000000-0_RetentionDate_None_folder.step.Document.Retention.HEAD"></label>

Change History (4)

comment:1 Changed 6 years ago by bill

Owner: set to myu1
Status: newpending

I have no idea... the code above isn't even referencing dojo, so perhaps this is unrelated to dojo.

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.)

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:2 Changed 6 years ago by bill

Component: GeneralAccessibility

Also, if there is a dojo problem, it's likely something that was fixed in Dojo 1.8.

comment:3 Changed 6 years ago by mikeb

In your code sample, the for="" value and the id of the image are not the same. Do you still see this violation if you make them the same?

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.