Opened 6 years ago

Closed 6 years ago

#16710 closed defect (invalid)

Bug in dojox.charting.axis...

Reported by: machandi Owned by: machandi
Priority: undecided Milestone: tbd
Component: Charting Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Bug found while is rendering an axis in Dojox charting.

As you can see in attached image, the “X” axis has two wrong numbers.

Beside I’ve attached de source code to reproduce this bug.

Thanks in advance, Best regards, Andrés Margendie

Attachments (2)

chart.html (9.5 KB) - added by jcmartin 6 years ago.
chart sample
chart.png (31.6 KB) - added by jcmartin 6 years ago.
Imagen of Bug

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by cjolif

Component: DojoX WidgetsCharting
Owner: changed from dante to Eugene Lazutkin

There is no attached source code or image that I can see, can you please add them?

Changed 6 years ago by jcmartin

Attachment: chart.html added

chart sample

Changed 6 years ago by jcmartin

Attachment: chart.png added

Imagen of Bug

comment:2 Changed 6 years ago by cjolif

well to be honest I actually don't understand why it is not worst than that because you are specifying an array of labels to your x-axis that do not correspond to what you seem to need. Have you tried just commenting your x-axis labels:

		chart.addAxis("x", {
	//		labels : labelX,
			rotation : 270,
			includeZero : true
		});

does it give the result you expect?

comment:3 Changed 6 years ago by cjolif

Owner: changed from Eugene Lazutkin to machandi
Status: newpending

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.