Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1671 closed defect (fixed)

item.create is not a function - Editor2 conflict with prototype

Reported by: psomma@… Owned by: liucougar
Priority: high Milestone:
Component: Editor Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

Editor2 conflict with prototype in the nightly build (not in the release 0.3.1). In order to reproduce such issue simply add

<script type="text/javascript" src="/pathTo/prototype.js"></script>

in the head section of the nightly/tests/widget/Editor/test_Editor2.html

The firebug report

item.create is not a function bootstrap1.js (line 754)

Change History (8)

comment:1 Changed 13 years ago by bill

Milestone: 0.5
Owner: changed from bill to liucougar

Cougar says that this is due to a mozilla bug but he lost the bugzilla bug #. Also, are you using the latest prototype?

comment:2 Changed 13 years ago by liucougar

line number is wrong in the report, that is caused by the bug in mozilla, not this bug itself

comment:3 Changed 13 years ago by erjica@…

I have this problem with Prototype version 1.5.0_rc0 (from Ruby on Rails)

comment:4 Changed 13 years ago by erjica@…

Opera also has problems with prototype and item.create

Here is the trace from the latest opera.

Event thread: load
Error:
name: TypeError
message: Statement on line 554: Type mismatch (usually a non-object value used where an object is required)
Backtrace:
  Line 554 of eval script 
    item.create(node, this);
  Line 224 of eval script 
    this.postCreate(args, fragment, parent);
  Line 762 of eval script 
    var ret = twidget.create(localProperties, frag, parentComp, frag["ns"]);
  Line 245 of eval script 
    return [dojo.widget.buildWidgetFromParseTree(ltn, properties, this, null, null, properties)];
  Line 299 of eval script 
    return dojo.widget.getParser().createComponentFromScript(placeKeeperNode, name, props, ns);
  Line 320 of eval script 
    var widgetArray = fromScript(tn, name.toLowerCase(), props, ns);
  Line 402 of eval script 
    this.toolbarWidget = dojo.widget.createWidget("Editor2Toolbar", tbOpts, this.domNode.firstChild, "before");
  Line 617 of eval script 
    this.editorOnLoad();
  Line 553 of eval script 
    this.onLoad();
  Line 16 of eval script 
    return fcn.apply(thisObject, arguments);
  At unknown location
    [statement source code not available]

comment:5 Changed 13 years ago by dylan

Component: WidgetsEditor

comment:6 Changed 13 years ago by liucougar

Milestone: 0.50.4.1
Status: newassigned

comment:7 Changed 13 years ago by liucougar

Resolution: fixed
Status: assignedclosed

(In [6343]) fixes #1671: item.create is not a function - Editor2 conflict with prototype

comment:8 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.